Tube's ZB Coordinators and Routers (was Zigbee router on steroids?)

unfortunately that leads to the exact same behaviour.

last try, please try flashing over serial/usb the esp32 with the binary found on github:

https://github.com/tube0013/tube_gateways/tree/main/models/current/tubeszb-cc2652-eth_usb/firmware/esphome

https://github.com/tube0013/tube_gateways/tree/main/models/current/tubeszb-cc2652-eth_usb#esp32-flashing-mode---esp32-serial-connection-via-usb

when i try to flash via usb there is an error message:

Unexpected error: The firmware binary is invalid (magic byte=0A, should be E9)
Did i took the wrong firmware?

Likely didn’t get the actually binary from Github, you have to make sure you click on the raw version to download the binary.

https://github.com/tube0013/tube_gateways/raw/main/models/current/tubeszb-cc2652-eth_usb/firmware/esphome/tubezb-cc2652p2-ethusb-2022%20(Rounded%20enclosure).bin

thx again.
that worked.
Flash of the esp32 was successfull, but the disconnect still exists

any other option to try?

Can you reach out to me at the store email - store @ tubeszb.com - I fear the radio may have died which I definitely have not seen occur in the past. But would like to work with you to get a working device.

great news. it works again.
Not shure, why exactly.
i´ve connected the coordinator to another switch with another powersupply.
→ nothing changed
i switched the ip address of the coordinator and tried to reconfigure ZHA in HA.
→ stoped with an error message but ZHA tried to connect with the new IP
i switched the ip back to the old one and reconfigured ZHA again.
→ reconfigure process successful and connect to the cooardinator got back online.
restart ZHA
→ connection to the coordinater works like a charme.

But the error in Tubes ZB flasher add-in is still there:

Connecting to target...
ERROR: Timeout waiting for ACK/NACK after 'Synch (0x55 0x55)'
[19:47:46] INFO: cc2652-flasher-up script exited with code 1
s6-rc: warning: unable to start service cc2652-flasher: command exited 1
s6-rc: info: service banner: stopping
1 Like

I learned the hard way that some network switches will cause a failure with some devices. I have no idea why. The Philips Hue hub specifically states not to use it with a switch and I’m guessing for this reason.

I have 3 network switches and found 1 will cause some devices to drop from the network randomly. The 1 I am using with my Tubes ZB coordinator works, but if I have a power outage it won’t connect after power is restored. I then have to unplug both power and network cables and plug them back in.

Hi @tube0013, I have your PoE Coordinator (tube-zb-gw-cc2652p2-poe) purchased a couple years ago, I think running 20210708 firmware? Are you aware of any issues with pairing Ikea Tradfri Repeater E1746? I’ve never had any issues with pairing devices in the past but got a couple of these and not seeing any pairing attempt in Zigbee2MQTT logs at all. Many thanks

I’m not aware of any issues. generally when you don’t see pairing attempts the network isn’t see them, as the device is responsible for broadcasting those. FWIW I ended up removing all the Ikea repeaters on my network a few months ago.

I got them on a whim as want to have a couple of zigbee devices in my greenhouse, but it would seem the toughened glass completely drops the signal. So my thought was to put a repeater in my shed to see if it is strong enough to get thru the glass, as the signal from my house is about 8m further away. Do you know how the signal strength of your repeaters compares to the Ikea repeaters?

it should be better, I’ve also been impressed with the third reality plugs as repeaters.

I put some soil sensors out in my garden. it’s about 8-10 meters from back of house. the sensors are joined to mesh through an ikea hue bulb in my attic though, so you may want to try staging a routing device high up to see if it gets better range. Inside the back wall of the house are a bunch of plugs and bulbs, and it still chose the attic bulb as the best router.

I’m sure its the toughened glass that’s killing it. Will try in the roof of my shed, as its less than 2 metres away from the greenhouse - can’t get much closer! Not sure third reality is a thing in the UK. If I can prove some sort of signal in to the greenhouse I’ll order one of your repeaters, but need to confirm a reliable signal first.