Turn off scroll bounce for tablet view

The front end is great. But when building screens custom for fitting within a tablet (HassIo app) used for dashboard the un-intentional scroll bounce for the page even when there is noting below fold creates problem for easy interaction with buttons and small levers such as volume or dimming.

anyone got any solutions for this?

Did you managed to find a solution?

Also wondering this, a bit late… any solution?

You can do this with the card-mod addon and a custom theme.

Example custom theme:

  card-mod-theme: scroll_lock
  card-mod-root-yaml: |
    .: |
      :host {
        position: fixed;  # disable scrolling
      app-header {
        display: none;  # disable header

card-mod: GitHub - thomasloven/lovelace-card-mod: 🔹 Add CSS styles to (almost) any lovelace card
theme discussion thread: 🔹 Card-mod - Super-charge your themes!

Interestingly, this scroll lock custom theme works if loaded from the UI but not if the theme is called from inside the view (though everything else about the requested theme loads correctly).

Does anyone have an idea on how to lock the scroll on a per-view basis rather than for every view on the device?

1 Like

I’d like to see this too.