Turn on/off autolock on IDLock 101

I have an IDLock 101 which is set up securely and working as expected.
In the set config params, it is possible to set a config that locks the door automatically when the door closes. I’m able to set this parameter manually using the zwave settings in HASS, but if I try firing the zwave.set_config_parameter, nothing happens.

I want this function enabled after 19:00:00.
So, can anyone see why this zwave.set_config_parameter action doesn’t work?

alias: "Autolock on"
  platform: time
  at: '19:00:00'
  service: zwave.set_config_parameter
  data_template: {
    "node_id": 10,
    "parameter": 1,
    "size": 1,
    "value": 1

Here’s what the manual says:
Door Lock Mode(s):
Autolock Mode, Manuallock mode, Activate Away Mode, Deactivate Away Mode
Default Value : 1 ( Disable Away / Auto Lock Mode )

Name Parameter Number Size Value Description
Door Lock Mode 1 1 0 Disable Away Manual Lock
1 1 1 Disable Away Auto Lock
1 1 2 Enable Away Manual Lock
1 1 3 Enable Away Auto Lock
1 Like

I have been meaning to do the same thing, but I never got my id-lock to work with HA. I see the lock in my z-wave environment, but when I try to lock or unlock the door, nothing happens.

Do you have any advise on how to make the lock work with HA, or can you show any code snippets where you actually lock or unlock the door?

I would be more than happy to experiment with the lock settings once I get the lock working :slight_smile:

I had that same issue, but it was fixed when I added a network key to my zwave setup and re-added the lock.

In the configuration.yaml:

     usb_path: /dev/ttyACM0
     network_key: !secret zwave_key

Then, locking the door is as easy as doing this:

       service: lock.lock
            entity_id: lock.id_lock_id_lock_101_locked

I don’t understand how I could miss this in the documentation. I have read it several times, but still I have overlooked it every time. Now I have another problem, though. Sorry for halfway hijacking your thread, but my ultimate goal is to do exactly like you want in this thread. Now, however, I am unable to delete the lock from OZCP. I will try to do a factory reset of the door, and see if that helps.

Thank you for helping out. I will follow up once I have the lock working.


I am considering buying the Z-wave module for my Idlock 101.

May I ask you how your setup is with Hassio. And if you can share your code?

Do you have a separate App for the lock, working with Hassio. Or do you control the lock from within Hassio, and if so what kind of functionality have you deployed?

Please advise.

(RPI3/Z-Wave Aeon Labs Z-Stick Gen5/Hassio 0.60.1)

Sorry for the late reply.
I haven’t done much worth of integrating with the lock. It pops up once you add it to the z-wave stack.
No app to accompany the lock.

The only code I have is that I have added it to my good night script which is as easy as doing this:

- service: lock.lock
    entity_id: lock.id_lock_id_lock_101_locked

Thanks for replying. I’ll see with time if I’ll get the Z-wave module for the lock.

Hi, different topic but same lock (ID lock). How did you pair your ID-lock? Do you use a z-wave USB or controller? I added my lock through a Aeotec z-stick, it shows up in Home assistant, but the status is wrong and nothing happens when I press LOCK. Any advice? Thanks

The lock has to be added securely in order to be controlled.
You have to add a network key to allow for that.

I have set up Z-wave with a key so Thor should be ok. I added the lock securely and “normal” but the same result. Did you have the controller close while pairing? My controller is 5m away and not very easy to move.

I can’t say for sure why it isn’t working. 5 meters should be no problem, even with thick walls. I also have the z-stick.
I don’t know your level of understanding of the zwave system, but I struggled a little bit to get the key to work. I had to read the logs to make sure the key was correct and that the zwave devices connected securely.

If you only have these two devices, it might be a good idea to buy another portable zwave device and perform some trial and error to get up to speed on the inner workings of the zwave protocol.


Finally I got it to work! I had to take my Rpi with z-stick and put it next to the lock (5cm), then run add secure.

Aeotec z-stick
HA 0.79.3
Zwave config with network key

Hey guys,
I am in somewhat the same spot here…and I am a newbie, think you could help out?

I have:

Aeotec gen 5 z-stick
HA 0.87.1
ID Lock 101 with z-wave module installed

The lock works just perfectly, and is also found by a Samsung SmartThings hub I use for the moment, but not that happy with that solution.
So now I am trying to include the z-stick with the ID Lock.
I have followed the manuals for inclusion on the ID Lock, I have got the stick installed in HA (at least it shows up?), and I have tried to include the stick with the lock, but the stick isnt showing any sign of including the lock, even if the stick is just centimetres away…

What am I doing wrong?


you need to ad it secure to homeassistant, enable secure devices and generating a cod line that you put in ha. then it should ad just fine.

What is this module? Does it work in Home Assistant?

I’ve never heard of your lock before. Is it a standard zwave lock?

You might be interested in this lock manager I created.

It’s a Norwegian developed Z-wave door lock https://idlock.no