Turn on the light intent?

I have a Wyoming satellite configured in a room. I expect that when I say “turn on the light” home assistant will turn on the light in that room. However, home assistant is not able to match my command to any intent. Any ideas why and how to solve this?

So to confirm, the satellite is considered to be in the room, in the device section? Like in the below image:

And is the same set for the light as well?

I tested this in the satellite pipeline debug in the Assistant section by typing the command and it failed, however when I spoke it worked just fine. Have you tried saying ‘Turn on the lights’ even if there is just one light?


Ok but are you actually speaking the words ‘Turn on the lights’ to the satellite? It doesn’t work when you type since the Assist debug is just a generic implementation of the intent pipeline; the same when you use the chat in a browser - it won’t know what room you are in.

The room awareness only works via voice, spoken to the satellite, not to the companion app and not via text.