Turning on scene flashes last scene

Hi all!

I have three Sengled Zigbee color bulbs (E11-N1EA) configured in a lighting group. I have four scenes configured- Normal, Off, Blue dimmed, Red dimmed. Whenever I first turn on the light by selecting a scene, it will always flash the prior scene before setting the correct scene. For example, if I set the Blue dimmed, then select the Off scene, then select the Red dimmed scene, it will flash the Blue dimmed scene before setting the Red dimmed scene. Is there a way to make the Off scene reset the bulbs so they don’t call the prior scene first before setting the selected scene? It’s particularly annoying if I set the Normal light, then selecting the Off scene and picking a dimmed scene the next time as the Normal scene makes it flash a bright normal light.


Are you using a Home Assistant scene? If so, that’s normal behavior and not much you can do about it.

You can move the bulbs to using a ZigBee based scene instead and calling it. How you dot hat will depend on the ZigBee integration you are using.

Hi Ryan,

Thanks for the reply. Yes, I’m using the Home Assistant scene with ZHA. I’m thinking about changing to Zigbee2MQTT. Do you know if that would work better?