Tutorial: compiling open-zwave-control-panel


#61

Hello,
tcp 0 0 *:8888 *:* LISTEN


#62

Ok, so it’s listening on all IPs on that port - And you’re going to your browser and typing:

http://x.x.x.x:8888

(where x.x.x.x is the IP address of your HASS server)

And it’s not working?


#63

Browser is trying to connect but it takes too long so all I get is “Too long to respond” error message. May be its my Firewall settings?


#64

Ok. It was my Firewall settings. :flushed:


#65

I was going to suggest that, but I couldn’t think of a reason why you’d have a firewall between your testing PC and HASS :slight_smile:


#66

Why? So I can spend two days figuring out why isn’t something working even it should… :joy:


#67

When sudo make control panel i have this error.
Please help me…
I …/open-zwave//cpp/src -I …/open-zwave//cpp/src/command_classes/ -I …/open-zwave//cpp/src/value_classes/ -I …/open-zwave//cpp/src/platform/ -I …/open-zwave//cpp/src/platform/unix -I …/open-zwave//cpp/tinyxml/ -I /usr/local/include/ -o zwavelib.o zwavelib.cpp
g++ -o ozwcp -g ozwcp.o webserver.o zwavelib.o …/open-zwave//libopenzwave.a /usr/local/lib/libmicrohttpd.a -pthread -framework IOKit -framework CoreFoundation -lresolv
g++: error: IOKit: No such file or directory
g++: error: CoreFoundation: No such file or directory
g++: error: unrecognized command line option ‘-framework’
g++: error: unrecognized command line option ‘-framework’
Makefile:71: recipe for target ‘ozwcp’ failed
make: *** [ozwcp] Error 1


#68

ok i compilled ok
i must edit makefile for Linux

# for Linux uncomment out next three lines

LIBZWAVE := $(wildcard $(OPENZWAVE)/*.a)
#LIBUSB := -ludev
#LIBS := $(LIBZWAVE) $(GNUTLS) $(LIBMICROHTTPD) -pthread $(LIBUSB) -lresolv

for Mac OS X comment out above 2 lines and uncomment next 5 lines

#ARCH := -arch i386 -arch x86_64
#CFLAGS += $(ARCH)
#LIBZWAVE := $(wildcard $(OPENZWAVE)/cpp/lib/mac/*.a)
LIBUSB := -framework IOKit -framework CoreFoundation
LIBS := $(LIBZWAVE) $(GNUTLS) $(LIBMICROHTTPD) -pthread $(LIBUSB) $(ARCH) -lresolv

So just need to comment LIBUSB and LIBS for Mac OS X, then remove the comment for Linux. Then everything will be work.

But after run control panel on port 8888 run is ok but not show my controller and nodes … all is empty.


#69

It sounds like you now need to connect ozwcp to your controller. Go to the device panel near the top left of the page and enter your path to your controller. For example I am using a USB controller (Aeotek) on a Raspberry Pi 3. So in that box I type /dev/ttyACM0. Once you have done that you click the button to scan the controller.


#70

Hi there,
Im trying add somfy roller blinds + figaro fgr-222 + Aeotec by Aeon Labs Z-Stick to Hassbian. I wired everything and the blinds go up and down.
However, it doesnt go down all the way it stops somewhere 80% of the window.

So far i tried setting different parameters including parameter 29 with no luck. I do this in hassbian zwave interface.

I wonder if I can use open zwave native control panel to fix this at all? Reading this topic it seems that installing and running openzwave is a pain so i wonder if it worth it? Or does it have functionality to properly calibrate the blinds so the go all the way down…

Cheers,
Alex


#71

Does anyone have openzwave control panel working in docker on a rpi3? I’m trying the docker run command at the top of this thread, but it errors.