Tuya and Sonoff devices are changing MAC addresses proactively


I use pfSense and have a separate VLAN for my HA devices, which all have static IP addresses and there are some restrictions to some which can or cannot communicate back home.

I noticed few nights back that some devices are proactively changing their MAC addresses out of the sky thus messing with my DHCP settings.

Here is an example:

I wonder if someone ever had this happened before and how do you work around it?

Edit: This device can access internet.

Got the same problem with aubess diy smart mini switch under tuya. Messing with my wifi mac filtering. Can’t find where does it come from. Drove me almost paranoid…

Hi there, after further investigations I (hope?) Have found where it comes from. My aubess diy smart switch isn’t changing its mac address but tuya smart doesn’t reflect the right mac adress in the interface. Or maybe it reflects the bluetooth address and not the wifi mac address.
I opnened the web interface of my internet router which has a page that displays mac address of currently connected devices. I disabled mac filtering. I have my smart switch installed. Then i perform a strange gym consisting of switching on and off from my iphone while refrshing the web page on my computer (f5) until a new host appears in the list of connected device. Then i copy the mac address in the list of authorized hosts.
For my Aubess smart switch the mac adress is of the form c8.47.8c…which relates to beken corp, panufacturer of wireless devices…
No thanks to tuya for their vain support, no thanks to Aubess from whom I 'm still waiting for an answer…

1 Like

Same here.It’s the Bekens, same IP family. Every one of them.

Just adding my 2 cents on a similar issue I was having and I [hopefully] have just now fixed.

So I just added a new SmartLife switch yesterday to control some dumb lights. My network is a bit peculiar:

  • There’s private network a 2.4Ghz and a 5Ghz with the same SSID
  • Private SSID is hidden
  • MAC filtering is on, some devices are guided to the 2.4Ghz network, and other to the 5Ghz one
  • There’s also a public a guest 2.4Ghz network on another SSID
  • Public SSID is visible

There were a lot of variables to go through… I noticed this when I tried to connect the new switch and completely forgot I got MAC filtering on—and believe me, I tried numerous times!
At some point I realised my mistake and disabled MAC filtering to let the new switch connect. Then I went to the SmartLife app, looked up the new device’s MAC address, went to the router page, and added the new device’s MAC address to the MAC filtering page. Simple, right?

Except, it wouldn’t work. The weird thing is though, sometimes it would. It would go offline at some point, for some reason, even though I had just turned the lights on a few seconds prior.

I was having an internal battle between disabling MAC filtering on my private network—which I really didn’t want—or leaving these lights dumb—which I also didn’t want.

Long story short, I was reading through https://support.tuya.com/en/help/_detail/K9hut2s0mp5w0 (after having gone through this thread) when I stumbled upon:

  1. Wi-Fi needs to be broadcasted, cannot be set to hidden, and make sure that the mobile phone is using the 2.4G Wi-Fi band to add devices (check whether the 2.4G band and 5G band share a Wi-Fi account, if so, it is recommended to change to different accounts, and change to the 2.4G band network during networking);

And I thought: why not… Set the SSID visible, restart the router, wait a few moments for all the devices to reconnect. And surprisingly enough, that did it!

Note that all my other 20+ SmartLife devices were working just fine with the hidden SSID network. But something smelled fishy to me when the MAC address the SmartLife app reports on this new device was constantly offline according to my router. And yes, it’s also using a Beken Corp. chip.

Take it with a grain of salt.