Tuya bulb wont go RGB after being set to White

I’ve been searching around for some time and haven’t seen this issue. Please excuse if it is a duplicate.

I have recently added some Feit bulbs into Smart Life and then connected the Tuya integration. Everything seems to work fine (I can see the color picker, can turn on and off, etc) with the exception of trying to change from white to a color via HA Scenes or Google Integration (using Home Assistant Cloud). If I go in and manually pick a color from HA, I can then change colors via Scenes or Google. If I set the bulb to white via Google or using the color temperature bar in HA I can then no longer change back to a color unless I explicitly use the color picker in HA on the device. Not all my Feit bulbs do this, but most do.

So basically. If bulb is set to white, I can no longer change to a color except for using the color wheel in HA. Once I have changed the light to a color I can freely change the light to any color with any method right up until I set it to white (or soft white) and then I again can’t change it to a color until using the color wheel.

Any thoughts/recommendations would be greatly appreciated. Thanks in advance!


Having the same problem. Looking at the device in the Tuya Cloud Explorer the work_mode isn’t getting set from white to colour.

I posted a solution in the other forum discussion linked above.

Had this same problem. Found an alternative solution that makes the bulbs work as they should.

Set up Local Tuya with HACS. Ensure you have the latest version (currently 4.0.1)

Add your bulbs as new devices with the following settings:
Brightness: 22
Color Temperature: 23
Brightness Lower Value: 0
Brightness Upper Value: 1000
Color Mode: 21
Color: 24
Minimum Color Temperature: 2701
Maximum Color Temperature: 6499
Scene: 25