Tuya Bulbs Color (colour) not available in Tuya Local

I have been struggling with this one for a lot of hours over the last few weeks…

I had to apply a fix to get the bulbs working properly with Tuya Cloud, but now I have gone across to Tuya Local I just can’t solve this.

There are a number of other forum posts and solutions to getting bulbs controlled by Tuya Local to show the colour wheel. I think that I have found, read and tried them all, but try as I might I can’t get a working solution.

I have tried as many solutions as I can find, including:


Changing the number of supported features
Setting all the bulbs red in the Tuya app and then reloading Tuya Local

Since the change in the UI (and the removal of customise) a number of the solutions are not easy to effect.

A number of other solutions seem to have been depreciated and/or replaced as for most this problem seems to have been fixed.

I am working with 3 different types of bulb:
Novostella Dimmable LED Bayonet Bulbs RGBCW (RGB+2700-6500K White), WiFi Multicolour Bulb
LE WiFi Smart Bulb RGB Colour Changing, Warm to Cool White LED, 9W, Dimmable, 806LM, RGBCW
Avatar WiFi Smart Bulb E14 Light Candle Bulbs 5W 2800K Warm White RGBW Colour Dimmable

All the bulbs can be controlled through the Tuya app and have full functionality on there.

I have imported them through Tuya Local and they show-up and can be turned on and off, but no dimming and no colour control.

I have tried a number of changes in my config/customize.yaml

For example

light.novo_stella_2: min_mireds: 153 max_mireds: 370 supported_features: 63 brightness: 255 color_temp: 208 light.office_side: supported_features: 63 light.office_front_2: brightness: true color_mode: true supported_color_modes: hs supported_features: 63

I have tried just changing the supported_features numbers, adding in color_modes and brightness etc. but nothing seems to get me anything other than on or off.

This is probably really basic, but I can’t find a solution. Any help gratefully received.

Sorry about the bad formatting - new on the forum and haven’t worked it out yet.

Hey @GerryG did you get this sorted out? i just swapped from the official Tuya integration and have the same issue.

I got most things working as expected now. I will have to have a think to remember how I did it.

What are you struggling with?

I remember a LOT of trial and error, deleting the bulbs and reinstalling and using different settings each time until I had worked out all the working settings.

I got the on off / brightness / temp working. I found help here:

Below is example of values I used, after changes - reload config:

      "friendly_name": "local Light1",
      "brightness_lower": 29,
      "brightness_upper": 1000,
      "color_temp_min_kelvin": 2800,
      "color_temp_max_kelvin": 6000,
      "color_temp_reverse": false,
      "music_mode": false,
      "color_mode": 21,
      "color": 23,
      "brightness": 22,
      "color_temp": 23,
      "id": 20,
      "platform": "light"

I have a few different types of bulbs, from different places, and had them all linked to tuya, instead of their individual suggested apps.

When i went to tuya local, it took me ages to get anything other than on/off

in the end, i stumbled across the following, and deleted and re-entered each bulb using tuya local, and entered the numbers for the options as shown below

I now have on/off, brightness, temprature, colour and scenes

For DPS 1-10 bulbs:

    ID - 1
    Color Mode - 2
    Brightness - 3
    Color Temperature - 4
    Color - 5
    Scene - 6

    and for DPS 20-26 bulbs:

    ID - 20
    Color Mode - 21
    Brightness - 22
    Color Temperature - 23
    Color - 24
    Scene - 25

I love u man! Works for me!

This device:

1 Like

Thanks for the tips of the settings, with those settings I managed to setup correctly most of my lights!
I only have some ceiling lights that I cannot manage to configure the scenes as value 25 is missing from the options, I tried to use the 26 instead but without scussess.
All other features are working correctly, brightness, colors and temperature.

Any tip to setup this one ?

Hello … i just changed “color” to 24 and it worked perfectly for me!! :grinning:


1 Like

What if ID 23 is unavailable?

1 Like

Top post, love it!

works for me too. Amazing answer here!

Thank you for sharing!