Tuya device wifi connection issue

I recently invested in several Tuya devices after discovering the Tuya Local integration. Most are working well, but I’m having issues with a few.

My wife wanted RGB lights in our soffit so we could change colors for different seasons/holidays. We have a 2 story house with soffit lights ranging from 11ft off the ground to 33ft off the ground. Well, one of the lights that is 33ft off the ground is now having issues connecting. This particular light requires a boom lift to access and is wired on a switch with 12 other Tuya lights, so doing the power-cycle reset isn’t an option.

One of the lights, “Soffit Light 10” shows that is connected on my Unifi dashboard. It has a fixed IP address with no IP confilicts. It is not blocked from the internet by any firewall rules. However, it shows unavailable in HA and shows as “offline” in my Tuya Smart app.

Things I’ve tried:

  • HA reboot
  • Tuya Local Reload
  • Unifi network/console reboot
  • Confirmed no IP address conflicts
  • Confirmed the light is not blocked from the internet

Has anyone else had an issue like this with a light not connecting consistently?

I have one other tuya soffit light (also 33ft off the ground) that seems to disconnect for a few seconds every couple of minutes.

Using UniFi AP’s here too I have noticed that all of their AP firmware after v.6.0.21 leads to unstable wifi connections. If you are on a newer firmware downgrade to 6.0.21 (the AP where Soffit Light 10 and that other tuya soffit light connect to) and monitor if the problem persists.

Thanks for the tip. I’ll give that a shot

I know some time gone, but have you had any success?
Rolling back won’t be doable anymore for me.

Every device was working fine, now most are offline, but I can’t find out why. Even though connected to the same AP some work, most not.

Is there any way to get a bluetooth gateway running via LocalTuya?

LocalTuya is so much better.

  • no constant traffic home
  • devices controllable during internet lost
  • devices react far much faster

I rolled back my AP firmware and it did help. I still have some that are offline at times, but I’d say it made a big difference.

I’m using LocalTuya as well.

To which version?

I went back to v.6.0.21

That’s interesting. I checked all my updates and when I made them etc.
I thought first it was a problem at the Unifi side, but for sure it isn’t in my case. Why?
All of my devices connect without any problems. I can even restart my APs, all devices will come back online without any problem. At least from the network side.

But in LocalTuya most of the devices kept offline. So I backtracked everything I did and when the problem aroused.
First of all I just made an update to LocalTuya just 3 days ago. Before the update everything was running fine and after the update also, at least I couldn’t see any problem. Then I tried to find out what I did additionally and then I thought about my change.

For installation of new wall mounted lamp holders I turned of the power (also that of HA). I didn’t shutdown HA gracefully, it just went off. After I finished, the power got back and HA was restarted. I had the problem, that LocalTuya was showing nearly all devices as offline. Even though they were stable online in the network (ping test).
Restarting LocalTuya or any other HA component didn’t change a bit. Everything I’ve tested didn’t change a thing. Finally I remembered that I made the LocalTuya update. So I downloaded my backups and prepared for a rollback of my HA.
Then I remembered that HA has a shutdown command. So I decided to shutdown HA OP (not restart). After the restart, all LocalTuya devices came back online in HA except one. That bulb couldn’t come back, as it was turned off via switch. After switching it on, it came back into the network immediately, but still not in HA. So I used my smartphone and turned it off via Tuya App and bluetooth. The bulb itself I left powered. After some time (unfortunately I have no idea what time as I went to bed, but longer than 1hr), even this last device came back online in LocalTuya. Now I can even power down my devices and they will come back online without problems after turning them back on.

So I assume it is a problem in LocalTuya not my network at all as all devices are online stable in the IP network.

What do I use?

Unifi Dreammachine (UniFi OS UDM Pro 1.12.33) Network 7.2.95
Unifi AP Lite V6.2.49
Unifi AP U6 Lite V6.2.49

In network configuration I have everything off (IGMP Snooping, Multicast DNS)
In the WIFI configuration there is also everything turned off except UASPD and 802.11 DTIM Period
which is set to auto. Minimum Data Rate Control is set to manual and for both networks the minimum value is 1Mbps and 6Mbps.

I can even setup devices with 5GHz activated. The only devices I need to shutdown 5GHz network are my AIMASON plug sockets with power measuring. Once configured I can turn the 5GHz network back on. After setup they connect to WIFI even with 5GHz activated.
Now I have a special IoT WIFI, where I leave 5GHz disabled, but that’s not enough for these plugs. Any 5GHz network and they will fail to setup.

I don’t know what problem there is with the new U6 APs, but they can only be used for normal operation with Tuya devices. Setting them up is impossible with those APs. I have searched for it and it seem to have something to do with WIFI 6 which you can’t control.