Tuya devices have a 10 to 40 second delay

I can’t put my finger on the exact HA version where it changed, but in the past couple weeks I noticed that all of my Tuya devices take 10 to 30 seconds to turn on or off via Home Assistant.

If I turn them on via the Tuya app directly, or via Alexa, they respond immediately, so I wouldn’t think it’s on the Tuya end, but rather a HA update.

Has anyone else noticed their Tuya devices have a delay recently? Does anyone know the last HA version that didn’t have the delay?

It’s always been like that for me since I started. It’s due to HA having to go to the cloud to connect to Tuya devices and the only way to eliminate the lag is to control your devices locally by flashing them.

Here’s some more info on on of your options to do that. It’s been a pain for me trying to do it through a virtualbox VM but if you’ve got the tools it’s worth a shot.

It absolutely changed/started going from 0.105.5 to 0.106. I had the exact same symptom as soon as I upgraded, with the same result that Google home, Tuya app etc were immediate. I reverted back to 0.105.5 and it works fine with no delay, so something definitely changed in the HA code. I’m patiently waiting on upgrading until someone figures it out, Tuya is a big part of my infrastructure and I don’t want to go to Tasmota because then the only way to do Google Home control is by having Google Home control HA, which I am not ready to integrate yet. Everyone in the household is very used to the way it all works. At any rate same issue.

1 Like

I was able to confirm this. Rolling back to 105.5 made all of my Tuya devices instant, and rolling forward to version 106.0 made them all delay again. A correction on the timing though, the delay is between 10 to 60 seconds when I actually time it with 106.0.

I would try the flashing, but if this could be corrected via a Home Assistant tweak, I would prefer that since I have 45 of these Tuya devices, some of them embedded in walls, ceilings, cabinets, etc…

I’m a bit new here. Is there an official bug log that I can post this information in? I can’t seem to find it.

yes. something in HA changed. i flashed about half my tuya stuff with esphome.

liked it how it was before i flashed, to be honest…

now my colorlights are a pain to control. the white_value and brightness come on at the same time… and about 10mins later the bulbs overheat… and start turning on//off/flashing

it sucks, bad

1 Like

I just submitted it as a bug with a link to this thread. You have to sign up for Github to report an issue.

Issue tracker entry

1 Like

Thank you for doing that! I really appreciate it!

I believe this may be related to changes to helpers/service.py that is also creating a delay with remote control devices such as Harmony Hub. I created an bug report on github for that as well. I’ll make reference to this in the Tuya bug report.

I tried the 107.0 update today. It didn’t say this issue was solved in the release notes, but I tried it anyway. It did not solve it.

https://github.com/home-assistant/core/issues/32671 appears outstanding…

I’m still noticing that this is a problem, and there is an open issue on it. Does anyone know the typical length of time it takes to get this type of issue to a solution? I feel like nudging, but don’t want to make enemies of the guy who’s job it is to fix it.

my experience is that “performance” problems like this take a while to get looked at by someone who knows what they are doing, compared to an outright failure which usually gets fixed fairly quickly

nudge away…

I have the same issue, meaning that the switches receive ON/OFF command, the lights are turning on/off immediatelly but the status in Home Assistant is displayed with a huge delay. In time of minutes. It is very, very annoying. I am running on 0.111.4 Home assistant version.

Same problem here, just setting up Hassio as a newbie but my tuya lights work very slow turing on and off and status updates very slow too. But the tuya app works great and controlling tuya with google works good too. Running the latest version 0.112.4

Same issue here. The lights respond fairly quickly, but feedback is very much delayed. Sucks.

I was having the same issue on HA 0.109.3 with slow response time for the status feedback. Upgrading to 0.118.2 seems to have resolved this slowness to a great extent. What used to take 30 seconds to update the status now takes 2 - 3 seconds.

Iam on 0.118.4 and still over a minute delay maybe depends on something else other than the version?

This started for me since core-2021.2.3

Any solution?