TUYA devices (Smart Life) issue / devices state refresh slow


I had no problem adding my TUYA / Smart Life account and getting my devices added however, my issue is that when I change the state of a smart plug / switch from lets say, OFF to ON, the state changes after a very long time and I can’t toggle it back until that changes. Once it updates, I can change the state again. Basically this happens for entity switches, buttons, etc, in the UI.

Is this is a known issue? Is there a fix?


It is a known issue, search the forum, there are several topics about it. No fix yet.

Just now update to Home Assistant 0.113.0, and this work fine now…

I confirm, it is fixed with 0.113.0! Thanks

I just updated to HA 0.113.0, and still have this issue… switch updates after 30 secs… Is this the normal behavior? I just installed my first smart life switch today…

Updates happen instantly for me. Perhaps try to unlink and link again to the Tuya integration?

I did that… but nothing different happens… Maybe is because I’m using the smart life app? Should I use the Tuya app?

I’m using the Smart Life app and everything is working fine now since I updated to the lastest.

But, if you turn off light directly from the switch, you instantly show that on HA? I can turn on/off the switch from HA without problem, but if I change state from switch, update is very slow

It takes about 5 seconds. Perhaps it depends on your network latency, wifi issue perhaps. 5 seconds seems reasonable to me.

Ok, I’m going to look at that… thanks man!

1 Like

I’m seeing that as well. If I flip a switch that is on Smartlife it still takes about 7 to 10 minutes before HA receives an update showing the switch is on.

If I activate the same switch from HA the responce is instant. No more state switching back where it was.

OK so I didn’t try that so I guess the problem is partially fixed.

I have the same issue.
Switching de device using HA works very well!
The issue happens when switching the device outside HA (Tuya or Smart Life app, device directly, Alexa or Google Assistant). It takes random time to the HA to receive the information, usually more than 5 minutes, rendenring any HA automation based on Tuya devices almost useless…

I’m using docker HA version 0.113.3 on a Raspberry Pi 4 with 4Gb.

I’m using this integration with eWeLink and it works smoothly with SOnOff devices.

The same issue as described by @Guilherme_Wolf_Wande. Turn it on from Google or Alexa and the status does not update. I am using docker HA 0.115.2 on a Mac OS Catalina. Not sure what the issue is with Smart Life.

i have the problem too

Same here :frowning:

Hi all.

I have the same issue. I have already reinstall home assistant to the newest version this month(2020.12.1). From the scratch with new sd card running on rpi4 4Gb.

I can control tuya devices from HA with no problems. But if I change it manually the feedback refresh after 10-12 minutes.

If I check the TuyaSmart the feedback is there correct. I have tried to change the time for device refresh in tuya integration for 30s but it doesn’t help either.

Any idea? I gues it must be problem between HA and tuya. Because the feedback in tuya is true and fast.

Thanks in advance


I’m new to HA, just installed it on a Raspberry Pi 4 and I’ve also noticed the same lag - that’s crap if there is no fix

Well, it’s not a bug with HA but an issue with the API that Tuya obviously is in no rush to change.
Take a look here: Tuya devices stopped changing state

I have successfully worked around the latter by using local tuya from here.
Runs niclely together with the Tuya Integration to HA and the States of Tuya devices are upgraded intantly within HA whatever method the switch/light etc. was triggered from.