Tuya dimmer switch works only partially - On/Off but not dimming

With my earlier integration, these dimmer switches were working perfectly. After setting up the new Tuya integration, they only can do the on/off function but not dimming. Shows and allows me do the dimming on the slider bar in HA screens. But moving on the slider bar has no effect. Please suggest.
Home Assistant Core Version core-2021.11.1

1 Like

The same is happening here. I have a Gosund dimmer and the situation is exactly the same. I had to create several scenes in the Tuya application with different brightness values ​​and add them to the dashboard.

1 Like

I also have this problem. I opened this issue last night:

After some reading on internet, I figured that issue is in the same category of this issue: Tuya no dimmer (tgq) devices found · Issue #58627 · home-assistant/core · GitHub
I guess good people in the HA contributors group are working on it. Also, the device is working perfectly on SmartApp. I also tried by removing the device from SmartApp (it disappeared from the Tuya Integration on HA) and then added it back to SmartApp (It reappeared on Tuya Integration on HA). No change… same problem.

The device that is not working fully on TUYA integration shows as follows:
Device Information
Product Name: Smart Dimmer Switch
Device ID: 83150137d8bfc053f9a5
Product Category: dj
Device Status: Online
Activated At: 2020-03-04 19:40:49

Device Association
Project: Home Automation
Association: [email protected]
Data Center: Western America Data Center

Extension Information
Sub-Device or Not: No
IP Address: 99.999.999.999

One of my theories is it might be protocol version related. Apparently there’s version 3.1, 3.2 and 3.3 of the Tuya API. I have 6 devices, 5 are working fine on 2021.11.x, the one that isn’t is a 3.2 device. All the others are on 3.3.

If you play around with localTuya or some of the CLI tools out there, you can get them to report the protocol version of a device.

Thank you @Scope666. Assuming that it is of a version <3.3, do you have any suggestions on how to make it work? Can the firmware be easily upgraded? If yes, appreciate if you can send a “how to” link to that.

The integration itself has to be fixed. It was working in 2021.10.x and before, so they just have to figure out what they broke in 2021.11.x

I have two types of dimmer switches using Tuya. MartinJerry SD-KN01-1P which seems to be working normal with brightness changes, The Treatlife DS02S aren’t responding to brightness changes in HA. Sending brightness via the Smartlife app or Alexa and they work as expected.
I noticed the color_mode on the DS02S is shown as HS even though it only lists brightness and onoff modes. The MartinJerry shows color_mode: brightness
I see it’s being worked on…hopefully its easily fixed

This is still an issue, today I installed a 1-CH WIFI DIMMER SWITCH and it works perfectly in the the Tuya app but doesn’t appear like a light, let alone a dimmer, in HA.


same, have 4 light switches (gosund) integrated through Tuya, they dim just fine in Tuya and by Alexa, but do not dim with the slider in HA.

hey - did you ever fix this? I may make an issue in github as I can’t find any solutions yet

Guess not; I just opened a box of SW2’s to put a new one in and same results; several issues on Git that seem to be closed. I’ll report as well, love these dimmers; no Zigbee dimmer looks or operates nearly as nice as these; hate to see them not work anymore.

I did some more research before opening a ticket and found a reference to a different brand switch; but - the fix worked for me:

Set the brightness channel to “2”; Value 997.