Tuya Human presence sensor missing Illuminance

Hi,
I’ve bought me a Zigbee Tuya Human presence sensor and configured it successfully with Zigbee2MQTT.
But the Illuminance sensor is missing in HomeAssistant, in the Zigbee2MQTT dashboard I can see the the Illuminance value.
Is it possible to add this somehow ?

Zigbee-Modell TS0225
Zigbee-Hersteller _TZE200_2aaelwxk
Beschreibung 5.8Ghz Human presence sensor

2

thanks and regards

Hi Qwert1,

Did you check the sensors list in the device view of the corresponding device? Maybe the sensor is hidden or disabled. From the device page you can see all sensors/entities and enable them if you want.

If that doesn’t work for you, you can also try to add the sensor manually in the mqtt integration. MQTT Sensor - Home Assistant

1 Like

I would agree with @Jordo; I have the same device and they works great here - both the square and the long versions, I have one of each.

image

Hi,
thanks for your answers @Jordo @igorsantos07
I see the Sensor in the device but it has no value and is hidden.

in the state.json I see the value

    "0xa4c138e86008671a": {
        "presence": true,
        "motion_state": "small",
        "fading_time": 60,
        "illuminance": 830,
        "large_motion_detection_distance": 5,
        "medium_motion_detection_distance": 4,
        "large_motion_detection_sensitivity": 6,
        "medium_motion_detection_sensitivity": 8,
        "indicator": "OFF",
        "small_detection_distance": 4,
        "small_detection_sensitivity": 8,
        "last_seen": "2024-01-23T13:50:18+01:00",
        "linkquality": 128
    }

how does an entry in the configuration.yaml need to look like or I am missing something else ?

thanks and regards!

AFAIK this has nothing to do with configuration.yaml. I’m not sure why in your case the lux sensor got disabled by default (usually this happens with diagnostic data from Zigbee, so this is what I’m showing below, but the workflow is the same):

  1. click that disabled entity you circled

  2. press the top-right :gear: button
    image

  3. enable it, then confirm (in English the button is called “update”)

  4. wait a couple of minutes, and it should populate with the actual data :pray:

1 Like

Thank you so much, it worked. :slightly_smiling_face: