Tuya-integration does not update status anymore

Problem still exists in
Home Assistant 2023.5.3
Supervisor 2023.04.1
Operating System 10.1
Frontend 20230503.3 - latest

Logger: urllib3.connectionpool
Source: components/tuya/base.py:275 
First occurred: May 15, 2023 at 10:38:32 (1128 occurrences) 
Last logged: 19:24:12

Connection pool is full, discarding connection: openapi.tuyaeu.com. Connection pool size: 10

Issue opened a couple of weeks ago:

exactly the same situation here since some days.
3 tuya devices (AWATTO WSM02), HA Core 2023.10.4
I can switch them ON via HA, but they don’t get the recent status and i can’t switch them off from within HA.
But from tuya app on my mobile, I can switch them on/off and see the status.

Any Idea how to auto-fix or auto-repair it? My wife is quite upset about it, because I soldered the things into her favourite lamps :cold_face:

Can you use tuya local with those devices ? I have latest update as you and tuya switches are working.

No, it is not “tuya locally”. I guess, such does not exist entirely.
It is tuya via the cloud. Always. From Mobile via Tuya App or via Smarlife App, as well as from Home Assistant via tuya integration.

Following this. I have the same issue. I have reloaded the integration and was able to get the status reflecting accurately in HA dashboards. Will need to check if this is temporary or whether this has solved the issue permanently.

Hi @wkofangmar ,

I also had this week same issue again. Today everything seems to work fine again.

I have the same issue. I have 3 smoke detectors in the Tuya App and when they detect smoke, I get a notification from the App. But I don’t get any notifications in Home Assistant or Apple HomeKit. I also have to reload it first in Home Assistant to see the status respectively the log.
Is there a way to change the refresh rate?

It is now March, 2024 with HA Core version 2024.2.5. I have the same issue! HA is NOT showing the correct status (On or Off) of my 4 SmartLife/Tuya devices. When this happens, toggling the switch On or Off in HA, nothing happens on the devices. I have to manually reload the Tuya Integration in order to show the correct status of the devices. This is not a problem with the SmartLife App on my phone at all. It is just HA’s Tuya integration is buggy! I will probably dump my 4 SmartLife devices and delete the crappy Tuya Integration.

1 Like

Same on core 2024.3.0 here. I’ve got several Tuya devices via the official intergration = cloud. And just one temperature&humidity sensor doesn’t get updated in HA.
In SmartHome app it works just fine, but in HA I need to reload Tuya integration which renders the sensor useless.
I didn’t have any success setting up Tuya Local so far, maybe it’s time to give it another go both for Tuya Local and Local tuya, whichever would work.

1 Like

just FYI:
meanwhile I have 67 tuya devices here and everything is working fine.

I’ve managed to add the problematic temp&humidity sensor to Local Tuya after all and through Local Tuya it’s now been working fine for a day.
Still doesn’t work through official Tuya integration.

For those in the same boat, none of my Tuya temp&humidity battery-powered sensors keep their state in Local Tuya. Most of the time they would show “unavailable” and only for few seconds when the sensor updates the info they would show the acutal value. The solution for this issue is to create a trigger-template sensor that would hold the last known value of the LocalTuya sensor as described here

My localtuya devices unaiviable since 2024.3, reverted back it work. I use tuya too but no prob with.

Same trouble I’ve a motion detector. Tuya App receive update of motion but HA not after Integration reload the status change. It seem that pooling don’t work anymore.
Update Status :
HA => Tuya work
Tuya => HA don’t work

To who has no problem which I the setup?
My Tuya zigbee device are connected through Z2MQTT… does any one using Tuya hub? Could be that the problem?

The original post was about tuya wifi devices and the Tuya (cloud) integration

1 Like

Very same problem for me. Motion sensors stopped working a while ago. Thought it was me who misconfigured something.

Turning lights on and off via ha works, but the polling is broken.

just want to add my 5 cents here.
I had the same situation where I could not turn off a switch because HA thought it was already off whereas it was actually on.
What I did - I removed LocalTuya integration from HACS (and rebooted HA) and it magically started working!
It may take a couple of seconds delay but - still working.
Or maybe it is only because I rebooted the HA?

its due to the reboot - when the Tuya integration starts, HA sync’s status of your devices with the cloud.

At some point, status updates will be missed, and HA will have a different state to reality.