Tuya Integration - Error 2406: skill id invalid

Overnight my Tuya integration starts working again without any intervention. :wink:
Definitely a Tuya side issue.

1 Like

mine just stopped {‘code’: 2406, ‘msg’: ‘skill id invalid’,etc…
currently i applied for trial extension,and iot.tuya says Your application for extension is being reviewed

This worked for me. Thanks for the insight.

SUPER!! Thank you!

1 Like

This solution works for me. After I lost Internet from my home and had to restart my Internet router. For some reasons, my Tuya integration stops working. After I delete the Tuya integration and try to re-add it again in Home Assistant, I ran into this error “Logon Error (24066: Skill ID invalid)”. After double check on https://iot.tuya.com that my ID/password to this site is still correct and my AccessID and Access Secret is still correct, but Home Assistant kept giving me this Logon Error. I followed this instruction here by go to iot.tuya.com and after log in with my ID, I unlink my previous linked account and then follow the instruction to link my Tuya Smart App account again, then immediately all my tuya devices from Home Assistant started showing up again.

This is the way, thanks

1 Like

Here is the solution!

I am now able to connect to iot.tuya.com and the TUYA integration is connected in Home Assistant but my Jinvoo smart wireless WiFi plug smart water/gas valve no longer appears in Home Assistant. Any suggestions appreciated.

Thanks for a great information but I only understand English!!

Perfect thank you. After unlinking and relinking I just had to delete the integration and re add it without changing any password.

After adding the Tuya integration are you seeing the devices that are linked to your account? I am having issues where it shows no entities/devices.

Omg!!! Bless your heart! My 6 months expired and this has been driving me crazy. Good job and thank you for sharing screen shots!

I’m trying to set up the Tuya integration for the first time and after trying for 2 hours I’ve hit a brick wall. I’m in the UK so changed my data centre to Central European as listed, but got the “Skill ID invalid” message. Just as a last resort I changed it to Western America, and if I then change my location to United States I don’t get this error message but a “Login authentication failed”. I’ve checked the details I’m putting in meticulously and have unlinked and relinked the app until I’m dizzy but got nowhere.

I have 13 Smart Life plugs around the house, forming the bulk of my smart home and I didn’t realise that integrating them into HA would be so problematic. I guess I should look at putting Tasmota on all of them, but then that seems to be problematic if they don’t contain the right chip, from what I read. Is there another way?

I made a new project with all permissions and 2 regions: central and west europe (it seems the netherlands is central instead of west…)

after that I got 1106 permission denied instead of skill id invalid.
I got the same error, when I try to use the "Get the device information’ call in the api explorer in the tuya iot cloud

But when I try another “Get Device Information” call in the api explorer tree, it works!

so got some devices working now through localtuya and getting the local key via the api explorer
(but yes, much more troublesome than it should be!)

1 Like

Thanks, I had seen this but it didn’t work for me, but I’ve since discovered Tuya Local and that works perfectly.

I try to unlink my device @ iot.tuya but there are no devices and in the app there is no connection to a cloudservice, but when I try to connect the device I get an error:

No clue, what to do!?


Unfortunately, I am getting the same error!

you need to unlink one project before you start .