Tuya Integration HA 2024.02 - QR-code

Hello guys,
I have just updated to HA 2024.02 and wanted to take advantage of the new Tuya Integration.

Having a developer account with Tuya is no longer required; instead, you can scan a QR code with your Tuya Smart or Smart Life app to authenticate it with Home Assistant.

The thing is I’m getting this error: “Login error (0): Login failed, please scan and try again!”

I tried to login from a web browser (Chrome), since I have to use my phone to scan … I guess.

Has somebody had the same issue?
Thanks

2 Likes

Change your wallpaper to default

2 Likes

Which wallpaper are you talking about?

Tried to use my iPad app, which shows the QR-code properly.
Also Firefox works and shows QR-code.

The issue is with Chrome, which I normally use because it has more compatibility with HA.
Bye

2 Likes

For my part, I’ve got the same issue. I changed my theme (google dark) back to home assistant theme and it’s working well now.

Go to your profile, click on your picture/name at the bottom left, see the theme and change it back.

Regards

4 Likes

I had to use iPad HA app to scan QR code on phone for Tuya

there is a lot on this already. You likely use a custom theme. Switch to the default theme and then this should work.

1 Like

Anyhow I think it’s a bug with the browser … in this case, for a one time login, I prefer a workaround.
Generally I use Firefox (which is dark too in my cas), Chrome just for HA.

And let me add, I will stay with LocaTuya, rather than a cloud integration, which I really don’t need in the end!

When I decided to configure the official integration, didn’t notice it was still cloud!
Bye

Refreshing clearing the cache (Ctrl+F5 on Windows) fixes the problem.

3 Likes

Great ! solver with firefox.

Can you explain how??? this whole thread sounds like gibberish to me. I have HA running and I see the QR code. when scanning it with my phone it just opens a search page nothing else. Befor the integration worked fine

In the Smart Life app, click the plus button in the top right, there should be three options in the drop down list, click Scan and you are good to go. Don’t worry it took me about 30 minutes to work it out!

1 Like

Same problem here. I’m scanning the QR code and it says “no access”

Nothing, I have the same problem, empty white QR image, not even a white image on the app. Both Firefox and Chrome same problem.
My integration is therefore blocked… let’s hope for an update soon!
Immagine 2024-02-11 120433

I solved it like this:
Browsing through this extension, i already had this installed, i often use it to access the GUI’s devices such as the Shelly when I am away from home.

There is however an open official Bug Issue:

I’m still struggling with this…

The QR code gets scanned but I get a message in the Tuya app telling me that it has expired.

I close the window on Windows Chrome and then click the “Reconfigure” button again to get the QR code to show again. I try scanning again using the Tuya app and get the same error.

I have tried removing the HA dark theme, I am already using the Chrome default.
I have tried clearing the cache and cookies
I have tried using Edge instead
I have tried the Private and Incognito modes for Edge and Chrome

Any ideas?

This worked for me with the Edge browser.

Hello to everyone in this community

I have the same problem.

I have already tried the following:

  • Microsoft Edge on my notebook

  • Google Chrome on my notebook

  • Firefox on my notebook

  • Microsoft Edge on another notebook

  • Google Chrome on another notebook

  • Firefox on another notebook

  • Microsoft Edge on Android smartphone

  • Google Chrome on Android smartphone

  • Microsoft Edge on Android Tablet

  • Google Chrome on Android tablet

I also only ever get the white QR image

Hello again.

It’s true, I’ve changed the Theme from Home Assistant to the “Theme: Home Assistant”

IT WORKS :slight_smile:

1 Like

For my part, I’ve got the same issue. I changed my theme (google dark) back to home assistant theme and it’s working well now.

Go to your profile, click on your picture/name at the bottom left, see the theme and change it back.

Regards

Thank You - this one worked for me.

1 Like