Tuya integration suddenly stop working

Hi. Please i need some help. My tuya integration works many day without problem but one day suddenly stop working. I can’t see tuya entities. On my floorplan are only orange triangle which says: entity not available
So i did a full restore from my backup from the day it worked but tuya still not working. How is it possible?
Thank you and sorry for my english.

Sounds like your tuya account expired

Expired after month? Why?

go and into you tuya dev portal and have a look

When you go to the integrations list (Settings > Devices & Services) and look for the Tuya integration, is there any error message? Are all your devices listed there?
Any other log message related to your Tuya integration (Settings > Server > Logs)?

having the same issues my account is live and they work with google

Same here. Tuya integration suddenly stopped yesterday the 14th. I get a “MQTT config” error message in my log.

2022-11-15 16:24:09.510 ERROR (Thread-3) [tuya_iot] error while get mqtt config 
2022-11-15 16:24:09.585 ERROR (Thread-3) [root] Uncaught thread exception
Traceback (most recent call last):
File "/usr/local/lib/python3.10/threading.py", line 1016, in _bootstrap_inner
File "/usr/local/lib/python3.10/site-packages/tuya_iot/openmq.py", line 161, in run
time.sleep(self.mq_config.expire_time - 60)
AttributeError: 'NoneType' object has no attribute 'expire_time'
  • I have chacked “Device status notification” (step 6 from documentation)
  • I have tried the “Automation” fix (well-known in the community from 2021)
  • I created a complete ne project in IoT and used the ID and key
  • Removed and re-installed the integration (with old and new IoT project)

I’m out of options right now. Any thoughts? And what about the expiration? Is tat a thing?
Perhaps an API REST change on the Tuya side of things?

BTW The Tuya app works fine, IoT sees my devices and even Google Home works with the devices.

1 Like