Tuya integration unable to connect?

This morning I woke up to the the Tuya integration unable to find any entity. Everything is fine in their app and in the could configuration, just HA cannot see any entity. Rebooting does not fix the problem, and the integration cannot be reloaded - it looks like it is stuck.
Has anyone else experienced anything similar?

I had similar issue… my ip address changed and it wasn’t allow in tuya api…the first time I changed it, it doesn’t work and after a day or 2 I had redo it and it worked.

can’t tell why and how but like i said start by checking your allowed ip

Tuya have purged any expired dev (trial) accounts, you need to renew it.

Same happened to me. Checking the logs I found this

2024-02-02 10:40:06.038 DEBUG (SyncWorker_7) [tuya_iot] Request: method = GET, url = https://openapi.tuyaus.com/v1.0/users/az1540849625156eCjjP/devices, params = None, body = None, t = 1706888406038
2024-02-02 10:40:06.139 DEBUG (SyncWorker_7) [tuya_iot] Response: {
“code”: 28841002,
“msg”: “No permissions. Your subscription to cloud development plan has expired.”,
“success”: false,
“t”: 1706888406089,
“tid”: “56a88792c1e111ee9ba54e7461b93a02”
}
2024-02-02 10:40:06.659 DEBUG (Thread-2) [tuya_iot] Response: {
“code”: 28841002,
“msg”: “No permissions. Your subscription to cloud development plan has expired.”,
“success”: false,
“t”: 1706888406610,
“tid”: “56f693c1c1e111ee8b7b7ec07c15e737”
}

It talks about cloud development subscription expired. I’m not sure what to do next. In the Tuya IoT page there are some steps to follow to “verify” my account, but the questions treat me as an “Entreprise”

This does not apply in my case :frowning:

I don’t have Cloud Authorization IP Allowlist option enabled

You mean create a new one from scratch? Or is there a process to renew an existing one @Tinkerer ?

Open a ticket with them…

you can also try to renew the application, which weirdly enough I never had to do and it says it was expired in 2022…

But yet, all my devices are gone and Im waiting for them to resolve the ticket.

Oh, I just went in and created a new account :smiley: after a couple of reconfigs, everything is working again with the new account.

I’ve raised a request to have mine extended - lets hope they accept that. I have tried creating a new account but the verification email never arrives. Also tried to instal the beta smartlife integration that work with the app - but that pulls down entities but there are no devices under them and everything shows as ‘unsupported’…

The way to integrate Tuya and Smartlife has updated very recently, I’ve really struggled to find accurate documentation in forums so hopefully this reply finds people. Here is a link to the guide you need to follow, we are using the smartlife HACS integration now, once I realized this the transition was seamless. How to Install Smart Life Integration (Beta)

1 Like

I tried the beta but it said every device was unsupported! Do I need to set them all up again in the app?! I have quite a few!

Yes thanks you that fixed it immediately. I installed it through hacs.

I’m having an issue with this which seems simpler, but has me stumped. I’m asked to reauthenticate the Tuya integration. I tried this initially on my phone (using the Home Assistant companion app) and was presented with a QR code that I was asked to scan with the Tuya app - something clearly impossible within the same device, unless I’ve missed something. I repeated the process on my laptop, entering the user code when prompted, and then saw the message below: no barcode, just an error. I thought restarting Home Assistant would fix this, but it hasn’t. Any ideas?

Use Smart Life app or Tuya Smart app to scan the following QR-code to complete the login.

Continue to the next step once you have completed this step in the app.

Invalid hex color: rgba(67, 73, 82, 1)<sub><sub>Text</sub></sub>

A further message asked me to reinstall the integration but, with no option to uninstall, I can’t do that either…

I got the same error @TyneBridges , tried removed intggration restarting HA. After adding integration again it worked.

How did you remove the integration? I couldn’t find any option to do that,so I ended up restoring my backup from just before I installed the latest update. That fixed things for the time being but obviously could be an issue if an update soon doesn’t remove the issue.

Same issue. Scanning the qr code give me an error: code expired. But, as John above, after restarting HA the process of re-authentication works just fine.

For any integration, click on the 3 dot it give you an menu. The last voice is to remove the integration.

1 Like