Tuya lights/switches delay in updating states, is it only me?

Thanks zlinoliver! I’ve just ported over back to tuya integration and seems great so far. As this issue seems to arise from resource exhaustion over at your end, hope there are monitoring mechanisms in place to auto provision as Tuya products increase market share. Else we will face this once again. Cheers.

Unfortunately, it still doesn’t work for me. :pleading_face: I have restarted HA multiple times since yesterday and there has been no change in behavior of my Tuya devices. There is still massive delay in updating their status. I will keep trying.

Did you try to resubscribe to ‘IoT Core’ Tuya API service? (If not please make a try, I’m just curiouos.)

Since I started my trial a month ago, this is what is says:

I haven’t changed anything.

Do you mean I should cancel my subscription and subscribe again? Thanks.

Wow, that’s much better. Almost instantaneous now. Thanks :slight_smile:

This is what me and some other people did yesterday and the problem seemed to be solved from that point. But also this is what generated some bad tone comments as our new subscriptions limit its expiration to 1 month in total, what of course could lead for uncomfortable results.

Anyway I (we) did it, and seemed it solved my (our) problems, but Oliver told that not this was what solve it. I just throw this tip for you, as yesterday it really seemed that this was what solved our problems and my problems are currently really be solved :slight_smile:

The choice is yours, but maybe this is really need because of some Tuya API ‘bugs’?!..

I resubscribed. But unfortunately it didn’t solve the issue. :pleading_face:

1 Like

Sadly in this case I have no idea. I had the ‘slow or wrong Tuya device state report’ problem (I made lot of tests around it) until yesterday, but from that point my devices work like they should.

On yesterday there were some HA changes behind Tuya integration, and some of us made a resubscription to ‘IoT Core’ API functions.

As lot of us report ‘corrected’ results - included me -, sadly, sorry I have no more tips.

This finally solved my issue. I thought I had “Device Status Notification” service authorized, but it wasn’t the case.

As stated by “wseltzer”, make sure you follow the instructions on Tuya integration page carefully and you subscribe to and authorize all these services:

(“IoT Data Analytics” is part of “Data Dashboard Service”)

Thank you for your help “wseltzer” and “Tamas.Toth.ebola”.

1 Like

It was already posted by dev, the issue was resources on the servers handling HA API requests. This makes sense, as slow, missing responses, assuming it was something like a http server running tomcat / okhttp ( or whatever they are using), if not resourced or tuned properly, will give exactly the same symptoms of slow and missing responses.

The only thing I could see where removing and adding the subscription would resolve the issue, is that this action re-homed your API requests to a server that was capable of handling the load, whereas other people were still homed to a server that was under resourced ( which they then finally upgraded ) .

It makes sense that if Tuya had a server where they knew there were resource issues, they would stop homing any new IOT Core subscriptions to it.

Hi all,

In my case, it still works with a long delay.

I have created another project to see if this fixes it, but continue with the time-outs.

The service " IoT Core" say “Subscribe : Trial EditionExpiration Time : 2021-11-28”,

I have requested renewal on several occasions and for several days, but I have not received any response.
How many days do they need?

Excuse me, my English is very bad, I use a translator.

I also realized that my IOT Core subscription ended after 1 month. I tried to renew but that failed because the system says I already have 1 subscription and I cannot have 2. I then clicked on extend subscription. I could chose to extend for 6 months and had to complete a form that is now under review. No idea how long that will take. I could not find a way to cancel and renew my subscription to start all over.


My IOT Core subscription is extended now, but this integration don’t work correctly.

Can you help me please?


I have a Xaomi Smart Space Heater (Tuya-based) that is also not getting the updates so I assume it is the subscription issue or cloud-based issue. So is the solution here to use the Tuya Local Custom Integration and flash the Tasmota firmware on this?

Thankfully this custom integration here: GitHub - ollo69/ha_tuya_custom: Tuya Custom Component for testing still works and updates the states properly. Also I can force my lights to have color attribute. :slight_smile:

Seems like some folks discovered an issue with the Tuya SDK, testing this fix, but need to wait about a couple hours: Tuya Integration apparently fails to renew cloud access token - githubmemory

1 Like

This is still very much an issue for me, tuya is not updating lovelace dashboard. I get this message in IoT tuya:

On October 15, 2021, Tuya has adjusted some API services, allowing you to manage them conveniently. We have integrated all the basic device management and control APIs into the IoT Core Service.You only need to subscribe to one service to get the complete device management capabilities.

This adjustment involves the following cloud services: industrial general device registration, industrial general device management, industrial general device status query, industrial general device control, industrial general user management, industrial general asset management, smart home devices management, and smart home family management.

If you have subscribed to any of the above services, the platform will automatically help you subscribe to the IoT core service without affecting your normal API calls.

Then when i got to add IoT Core it says i can’t as i already subscribed to something. I can only fill in a form to extend it with max 6 months.

Seems to be resolved now, i don’t think it’s lovelace, it’s tuya integration not updating the sensors correctly (it seems to respond though when reloading the integration, so maybe it makes an exception for the first call to the cloud API).

Funny thing is it was still responding to automations, so it does seem to have to do with the device notification subscription. Whatever the case, i’ve learned some lessons here:

-Keep automations simple, try not to rely on state variables (especially when set by external cloud based integrations). I had this cool audible “lights on” thing going and the lights on automation only running when the state was set to off, but i will just remove that stuff.

I’d rather have it running again (that’s what it used to do, every time it detected motion it would turn the lights on but if lights were already on, it would tell me in the log it was already running) then saying (or doing) the wrong thing because a sensor is not updated correctly. Simply things. Also, audible alerts get tiring after a while and it freaks out people who come over :-). A automated home should serve and disappear in the background.

-I need zigbee bulbs. Can’t flash my bulbs to tasmota anymore, they all have the new chip.

The answer is here. Scroll to the bottom

As Peter_Junker said. Disable the IPv6

I had only one lamp that suddenly had long delays when controlled from HA. I disconnected it from power and then reconnected. I think it re-registered at Tuya cloud and started to work immediately without any latency.