Tuya login error: Retrying setup: 'code': 2406, 'msg': 'skill id invalid'

Just started happening for me about an hour ago. Reboot HA didn’t resolve the issue. I can still control the lights through the Smart Life app. Does anyone have any suggestions?

1 Like

Same here…

Same for me, Invalid Skill ID as of this morning. I’ve restarted and tried to re-add the Tuya integration, but now I can’t login. I’ve also created a new Cloud Project on Tuya IOT as suggested in some older posts - no luck. I think it must be broken at there’s Tuya end. :slightly_frowning_face:

i can still use my IR heater, so cant pin it on Tuya atm. Or it’s only matter of time for me that the token needs a refresh… will see

I am having the same issue.

just want to add that I am having the same issue.

does anyone have a sugestion for a non-cloud based light bulb?

You can use Local Tuya but at the moment i don’t think that it’s gonna work. You need to find your local ID for each device and set it in Local Tuya and it should communicate but given the circumstances i am not sure if the initial communication will go through.

Local Tuya also won’t work if you have a separate IoT network after the 3.2 update last year. I had to move back to Tuya cloud because I don’t want all the devices on my main network.

You can use ZigBee bulbs locally if you have a ZigBee hub or dongle, but the bulbs tend to be much more expensive than WiFi.

Local Tuya works for me - link here. However, it doesn’t always play nicely with blinds/cover, not showing the current status, so I use the cloud integration for blinds. It is a bit of a difficult setup as well. I just reverted all my Tuya devices to local Tuya and can confirm it works.

interesting… could not get local tuya to set up initially y for my IR heater. Matching parameters was very odd to me and it did not get authorized at all i thought.

In the past month i used Local Tuya. I remember that i faced issues with devices being “unavailable” in HA while i could control them from the Tuya app. Not all of them but random. At that point, i decided to move to the official Tuya. Now there is a problem with that too.

I would like then to have a question. Can i be using both Official Tuya and Local tuya, for the same devices, if i name the entities differently?

Example: Device: Kitchen ceiling light.
In official Tuya the entity name will be: light.kitchen_celing_light_tuya
In Local Tuya the entity name will be: light.kitchen_ceiling_light_local

Can i do that?


Yes you can - there shouldn’t be any issue.

Thanks for confirmation… Then i guess, in my automations i will need to include both entities and in case one integration is not working the other one will take over…

Alright, got mine back up and running again thanks the instructions from @iSenne over here
Didn’t have to change my password either, just unlinked and re-added it back and all is working again


Thanks @vaughancoke, this worked for me as well. I didn’t need to change the password.

Thanks for this! I have had this error sonce yesterday, and the instructions that you linked worked for me.

Just for the record, this is the second time in several weeks I have had this error. The first time it seemed to resolve itself after a few hours, this time it has gone on for almost a day!

Thanks, this worked for me too.

1 Like

@vaughancoke worked for me too, thanks. I did have to change my password for the Smart Life app on my phone - I’d been kicked out and couldn’t remember the password. Not sure if this had anything to do with the Tuya connection breaking in HA or not.

Same for me, didn’t have to reset tuya password but the linked app was completely gone when I checked and I wasn’t able to use it, had to create a new project.

Same in one Home Assistant, but in other work fine. App OK.