Tuya Integration - Error 2406: skill id invalid

G’day, for an Aussies out here that have set up the Tuya Integration, what am i doing wrong?

  • I’ve set up devices in Smart Life app in Australian Region
  • Created a new cloud project in Tuya Developer Project in Central Europe Data Centre Region
  • Linked the Tuya app in the same data centre (can see all devices in the developer portal)
  • HA Tuya Configuration with Australia Region, Client ID & Client Secret from the project, Smart Life username and password.

I still get the 2406: skill id invalid error. Looking at the codes in the docs Tuya - Home Assistant. It appears to be either region or date of project creation. It’s a brand new project and it’s the right region according to the docs.

Anyone else experienced this issue and was able to resolve?


I have the same issue. I’ve recently migrated my Home Assistant from Raspberry Pi to a Docker installation, and when I want to login with the Tuya integration, I get this error:

Login error (2406): skill id invalid

In my Raspberry Pi, I’m still logged in with Tuya, and there are no problems. I even set up a new cloud project, but still no luck.


Oké, i’ve fixed the problem for me :slight_smile:

First I logged in the Tuya IoT Platform and unlinked the device in my old cloud project

Then, I opened the Tuya app (Smart Life in my case) and unlinked the old project again

Me -> Settings -> Account and Security -> Cloud Development Project -> [OLD PROJECT] -> Unlink

Now, link your device to the new Cloud Project

After that I changed my App Password (not the Tuya IoT Platform password)

Now it workes again :slight_smile:

Edit: I don’t know if the password change is necessary, It could be I tried to log in HA with the wrong password. But there are more people that did this


How Do I link my app account using Android? I have NO scan option
So I can’t scan the QR

(I went to ME (right bottom) and there are NO scan options

On iPhone it’s an icon that looks like this [-] in the top right corner

1 Like


That should be corrected in the instructions.
There it’s mentioned as “Scan”

This solved my issue!

Hello, have also this problem, but recreation of project and reinstallation of Tuya v2 integration didn’t help.
I’m wondering, what permissions did you guys set for the devices on import to iot-tuya.
Have complete set but skill_id invalid…


This working fine for me
Regards :wink:

I have fixed the problem by unlinking the app and link it again without any changes, creating new projects etc…


Confirmed, this worked for me. Wife and children happy again :relieved:

Happened to me today. All I did was unlink the app in tuya cloud website, and re-link it directly.
Reload the integration in HA and voilà
Thanks for this thread!


Had this problem since yesterday, this fix worked for me today, thanks!

It did it to me last night, too. I resolved it by going through the process of creating a new cloud project in Tuya IoT and then adding a new Tuya integration into HA with the new details, then disabling the original one. Devices have all come back with the same names, thankfully, so no need to change any automations.

It’s prompted me to look at LocalTuya, but that’s an even bigger nightmare, it seems.

It worked. Thankyou!!

Hello. I tried to do this but in smart life it says without permission in the integration… why is it?

No need to create a new project.

What I did was:

  • unlink project from “Smart Life” App
  • go to tuya ios development website
  • go to cloud section
  • clicked on my already existing project
  • go to tab “Link Tuya App Account”
  • then “Add app account”
  • then I opened the Smart Life App and I captured QRCODE that tuya website was showing
  • grant all devices all permissions (read, write, management)

that’s it

Home Assistant now can manage back all Tuya related devices!


Thanks for the detailed instructions. I did the same thing, except clicked unlink button in Tuya Cloud page. Worked just as well.

The problem started for me today when I added a png picture file to the Home Assistant www folder, and then restarted HA. Any idea of what causes this error to begin with.

Eventually I would like to get rid of using the Tuya cloud integration, but for some reason, I can’t get some of my temperature/humidity sensors, garage door opener, front gate opener, thermostat, and light dimmer to work reliably with ZigbeeHomeAssistant or Tuya Local.

1 Like

I got this problem. Just unlinked the tuya app and re-link, all working again. No idea what the cause is.

1 Like

I keep seeing people say to unlink the app, but where is this done? I’m not seeing an option at Tuya Smart Developer Center

1. Navigate to Tuya cloud: https://eu.iot.tuya.com/ (mine is on the eu region, yours could be in another)
2. Login
3. Click Cloud icon
4. Click Devices in top menu
5. Click Link Tuya App Account in submenu
6. Click unlink, 
7. Click Add App Account button, 
8. opened the Smart Life App and captured QRCODE that tuya website was showing 
9. grant all devices all permissions (read, write, management)