Tuya (or local tuya) smart water heater pump - not updating

Hello everyone,
I recently got a new water heat pump, and the external wifi kit uses smartlife app.
Tuya does not recognize any DP_IID’s but locaTuya does, and I’m able to get the ones that I want (current temperature, status, etc). However just noticed that the DPs are not updating, so I don’t get any temperature live updates.
The only way to get them is to go to the smartlife and, for instance, change the working mode from Auto to Eco, or equivalent. In that moment the other DPs ge updated in the Tuya Cloud and also in HA.
So it seems that the wifi module is not actively geting the updated device status.

Dows anyone had a similar case?

Hello guys, anyone?

I have an Energie brand, ECOTop heat pump water heater that I just had the WiFi adapter changed to one that is Tuya Smart Life based. The previous WiFi adapter was some proprietary system that only worked with the vendor’s app. I have tried to get this unit to work in HA using the Tuya Integration. The device shows up as “Smart Heat Pump”, but it doesn’t have any entities. I haven’t tried any other integrations like Local Tuya. Is this similar to what you are seeing?

I did the same. I had the old one and with the new module it uses Tuya platform. Unfortunately is not a tuya fully supported so in order to get data you will need to use Local Tuya instead.