Tuya problems

Why the Tuya v2 isnt working, detecting any device, and i can’t use the older Tuya integration?

Its setup correctly.

You can’t have both the HACS Tuya V2 and the builtin Tuya at the same time

1 Like

I wasnt able to delete the older integration.

Now, i finally can, and did it.

But, the problem continues, in the Tuya V2, no devices detected.

Still the same

In your tuya api/cloud can you see your devices under device management on the overview page? I wasn’t sure what server I was on, and at first didn’t have the correct one enabled, had to edit the profile add all the servers and go find them.

So I guess step 1 is make sure you can see your devices in the Tuya IoT Platform

Have you followed the instructions here? - https://www.home-assistant.io/integrations/tuya/

This new Tuya integration isn’t very user friendly at the moment with a lot of faffing about setting up a Tuya cloud account. The instructions above are very clear though. Do NOT use an adblocker when signing up for a Tuya account as just about everything will be blocked as it was in my case.

Tuya BHT-02 thermostat not working with Tuya V2.
The thermostat is homeassistant and appears in Homekit but works ridiculously. So it is not possible to use BHT-002.
Tuya light switch is working normally.


Yes, i did all the steps again and again, none worked.

I dont have any of these
Its just a door sensor (that i know that wasnt working in older tuya integration) and a switch lug, that was working well.