Tuya Siren Question

I’m on 2021.11.0b4 which says it now supports Tuya Sirens. I deleted and reinstalled the official Tuya integration, and the Siren now shows up, but it has (unsupported) next to the name and doesn’t create any entities. This is the siren I have:

Is this a bug, or is this not a Siren that will be supported? It shows up and works in the Smart Life app. If this isn’t a bug, is there a known Tuya siren that currently works?


same issue here

i have de same problem, in home assist integration tuya said “Smart Siren (unsupported)”, but entities not can see. :frowning: .

1 Like

Same issue :slight_smile:

Yup. Just tried mine, one device, no enteties. :frowning:

Same here. I was expecting at least those entities. Battery, sound on\off.

Me too even latest version of Home Assistant could not support Tuya Smart Siren H1 SOS which is sad.

Local Tuya could idenrify it but could not get the entities.

When will this be fixed ya?

It works with Tuya Smart Life App and there is no excuse not to work with Home Assistant.


My serene now shows everything including battery state, temperature, humidity, volume, time and switch on\off.

Me too. When I finally got the Tuya integration up and running, I found out it’s unsupported.

That’s sad. Any suggestion to an alternative product? We really need a loud siren so my wife, with bad hearing, won’t miss a house call from landlord etc. Flashing lights won’t help if you’re in the WC.

EDIT: I have a Nedis Smart Siren WIFISI10CWT.

I have this too. It support temperature, humidity, but not ringing.

Hi everyone,
Have you tried to add Local Tuya Integration from HACS and add the Siren directly to HA instead of using the Tuya Integration?

This problem with Tuya not giving any relevant or useful entities on HA happens a lot. Makes the integration it self quite useless.

I recently had that problem with an ProBreeze Tuya Humidifier and when I switched to Local Tuya HACS Integration I finally managed to control it correctly.

Hope this can help. If you need more details, just let me know.


Make a scene in Tuya and activate it in HA and it works…

1 Like

I am facing the same issue : Tuya official integration displays the device but without any entity.
When I try to add the device with localTuya, it just fails.

Anyone found how to use this device with HA?

Looks like ‘Rodrigo’ (above) has the answer. It’d be nice if he could share it!

Same here.
I have five wifici10cwt. Works fine in tuya app on phone and from iot platform.
Shows in tuya official but no entities
Local Tuya detects it (but none of my smokealarms) but there is no platform (switch light etc) that fits.
Tuya Local (not same as Local Tuya) detects it but give list of devicetypes not fitting with siren to select from.
My smoke detectors are working just fine with official integration.
I will try to create a custom config for the Tuya local based on the existing one for
Neo Coolcam Siren which looks to be similar to the point that the 10 first tones correspond with the wifisi10cwt