Tuya/smartlife problems (Thanh´s)

Hello, I am new to this community, I am from Spain, so first of all sorry for my English, I use the XD translator

A few days ago, I installed my first Home Assitant system and so far everything is fine … But since last night and after a restart, the plugin yours / smart life has stopped working for me is well configured and I have even installed a new system from 0 on a raspbian and then home assistant, I put the plugin of yours / smart life first and error.

There is someone else that is happening, or it is my problem … but it is very rare since it does not touch anything, and the smartlife app is fine, I leave you the error log, in case it can be of help. Thank you!!

Logger: homeassistant.setup
Source: components/tuya/init.py:63
First occurred: 10:43:24 (1 occurrences)
Last logged: 10:43:24

Error during setup of component tuya
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.7/site-packages/homeassistant/setup.py”, line 175, in _async_setup_component
component.setup, hass, processed_config # type: ignore
File “/usr/lib/python3.7/concurrent/futures/thread.py”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/tuya/init.py”, line 63, in setup
tuya.init(username, password, country_code, platform)
File “/srv/homeassistant/lib/python3.7/site-packages/tuyaha/tuyaapi.py”, line 43, in init
File “/srv/homeassistant/lib/python3.7/site-packages/tuyaha/tuyaapi.py”, line 65, in get_access_token
raise TuyaAPIException(message)
tuyaha.tuyaapi.TuyaAPIException: Get accesstoken failed. platform smart life not support!

Hi, I’m also from Spain, not sure if that has to do. But Tuya has stop working for me with HomeAssistant. It has been working for 6 months and suddenly 2 days ago is not working anymore

App works fine, but my switch are not being trigger from home assistant. Let’s see if we can find something out

Hello, thanks for the answer …

In the end I had to do a new installation, I tried a new installation and I log in without a problem, so I installed everything again. Well something I learned.

The night before I had tried to make the change from signing to a device of TUYA maybe that’s where the problem came from.