Tuya Soil sensor not recognized by zigbee2mqtt

I’ve purchased this Tuya Soil sensor after prior check on zigbee2mqtt hardware support list… The device is listed as supported.

Unfortunately after inserting batteries and allowing new devices to join, I only get this:

Note that the model TS0601 matches what should be supported. What might be the reason? Any ideas how to fix it?

Did you try reconfigure ?

Yes, it only shows this popup:

Then try to bring it close to your coordinator and re-pair.

This doesn’t change anything, during pairing, I was close and it slows link quality 220. I tried re-pairing several times but result is always the same.

Tuya is famous for selling the same device with different internal vendor names. Maybe the herdsman convertor needs to be updated.
Better file an issue here:

Which version of Zigbee2MQTT is running on HA?

As for Z2M v.1.38.0-1 and using the very same soil sensor model here it is working just fine (thus yours should work too):

If you run an earlier version of Z2M upgrade to the latest and try again.

Later in the evening when I have more time, I’ll try to debug it a bit more and also will submit the issue per your suggestion.

@Tamsy, I have all the latest updates applied.

I would remove that sensor from Z2M, restart Z2M and then do the pairing once again. Make sure the batteries are not weak!

Tried all that just to make sure. Deleted device, restarted whole HA server, added device - no change.
Batteries are brand new Energizer Industrial, measured 1.6V each.

I guess the problem is that this device introduces itself not as Tuya, but some other manufacturer. This is zigbee2MQTT log when pairing:

|[2024-06-21 19:59:05] info: |z2m: Successfully interviewed '0xa4c138bca1aa027a', device has successfully been paired|
|[2024-06-21 19:59:05] warning: |z2m: Device '0xa4c138bca1aa027a' with Zigbee model 'TS0601' and manufacturer name '_TZE204_myd45weu' is NOT supported, please follow https://www.zigbee2mqtt.io/advanced/support-new-devices/01_support_new_devices.html|

After a lot of digging, I guess I just need to wait for zigbee2MQTT update.

And support for my device has been added on June 2nd:

1 Like

I had the same issue with 2 of _TZE204_myd45weu. Just updated zigbee2mqtt to 1.39.0 and both have been successfully paired. I planted the sensors in the garden but both always show the soil moisture at zero. How can I debug the issue?

Force remove both of them, restart Z2M and do the pairing again one by one.

It worked! Thank you.

Good to see you have it solved. I can also confirm that my device works with the new zigbee2mqtt update. Until the update I used it with the zigbee2mqtt Edge version.

Just in case you may find this useful: I also noticed my sensor showing 0% for some time, but the reason was that I put it in a spot where it didn’t have zigbee signal reception. There were no errors, just no data updated. After moving it to another spot it works fine.