Tuya temperature sensor not provinding any values though supported by Zigbee2MQTT

I’m using Zigbee2MQTT to run Zigbee devices.
I bought three cheap temperature / humidity sensor last year, but found out, that they are not supported.

But with the Zigbee2MQTT update to version 12.8.3 support for this sensor came.
It’s shown as (translating it from German, so the wording might not be 100% accurate in English):
Zigbee Modell: TS0601
Zigbee Manufacturer: _TZE200_9yapgbuv
Manufacturer: TuYa
Modell: WSD500A
Supportstatus: supported
The picture is also correct.

So far so good, but though I could connect the sensor it does not provide any sensor value (except link quality).
So far integrating Zigbee devices was quite smooth.
Any advice what I can do the make the sensor working?


With some of the other sonoff devices, it is important to keep them “alive and communicating” during the initial setup. Done by repeatly press the “pair” button with a few seconds in between. Not holding it, as it will then reset and re-pair. Might be the same.
Remember to delete/remove it from Z2M first, before re-pair

Same issue, exactly the same, i have 4 sensors that are idling mounted

@khvej8 your trick does not work with my setup i guess :frowning:

anyone has an fix?

Have you tried this, from the Z2M device description, might be the same for the other entities.


If battery value is not showing in Zigbee2MQTT briefly pressing reset button AFTER device is fully paired usually resolves the issue

TuYa WSD500A control via MQTT | Zigbee2MQTT

yes i have, nothing works

been paired for like a month and never reported anything

Same behavior here, like “TheChemicalWorkshop” described.
Tried both advice “khvej8” gave with no success.
The sensor is still providing only linkquality (I assume that value is generated by HomeAssistent and not sent by the sensor), but no other value.

I wonder if it is possible to de-install and re-install Zigbee2MQTT without losing all device settings.
Since the update, that supports (more or less) the mentioned sensor, it always shows that an update for Zigbee2MQTT is available, but with strange version information.
It’s in German but I guess you can recognize the information.
If i try to run the update nothing happens.

Not sure if this is related to the issue with the sensor (all other devices continue to work normally), but maybe it’s worth a try.
Does anybody know if information about devichen es (and related automations, dashboards etc.) is preserved if Zigbee2MQTT is de-installed?

my current version is : 1.29.1-1
im not sure, would even offer a bounty to fix this sensor since i got 4 of them doing nothing

let’s hope someone comes up witha fix soon

here is more info i guess?

Since HA version 2023.1.x and Zigbee2MQTT version 1.29.1-x there are various problems/bugs with Zigbee2MQTT Addon. Koenkk knows that (this is a Zigbee2MQTT issue.) and he’s working on it. :wink:

This problem come with version 1.29.1-1 and i have the same problem with a Develco MOSZB-140 BWM_Zigbee2MQTT_Fehler

The other known problem since HA 2023.1.x is:
<class ‘homeassistant.components.mqtt.sensor.MqttSensor’>) is using native unit of measurement ‘’ which is not a valid unit for the device class …

All we can do at the moment is wait.

Has anyone found a solution to this yet? I just updated to version 1.30.0-1 but the error/problem still exists.


Zigbee2MQTT indicates that an update is being loaded, but the download has been running for hours and does not come to an end.

All a bit strange. After about 5 hours the download was finished and now I see firmware version 4.0.2 but with the same date 20200923 14:59

Under HA integration I see Firmware 3.6.6


Has anyone found a solution to this in the end? I have similar issue with 1.30.1-1 Zigbee2MQTT and 2023.2.5 HA versions.

updated to 1.30.2-1
still not solved :confused:

Is the error in HA or in Z2M? Because I don’t get any values in Z2M either.

Found this solution, but where is de data directory of Z2M inside home assistant installation?

Got them all three working. Only the battery status is off. % is not supported I think.

My trick that worked for me.

Set permit join only to controller
Add battery to sensor outside range of the controller
Push the reset button 10 sec so the led start blinking
Put the sensor neer the controller.

It seems the device then stays active long enough to complete the setup.