TUYA Zigbee Plugs 20A not detected by ZHA

I just bought some tuya zigbee 20a plugs for meassuring a few appliances at home. Unfortunately I’m not able to pair them with my existing ZHA setup. When pressing the power button for more than 5 seconds the led starts to slowly pulse but nothing else happens and in HA no zigbee device is discovered. Does anyone have a tip for me?


Have you tried initiating discovery by going to the Devices Settings, clicking “Add Device” and selecting ZHA? Sometimes that helps.

Be aware that Tuya Zigbee devices can be hit or miss and often include custom quirks. ZHA is often a bit slower to incorporate these compared to Z2MQTT.

Yeah that’s what I tried and I waited until the search timed out.
Do you have any other suggestion for zigbee plugs with power metering that work with zha?

I don’t have any personal recommendations for power metering plugs. Have you checked Blakadder’s database?

If you ask for plugs always tell what socket you use.

Sorry, EU Plug at least 16A 230V