Twilio Inbound Webhook Configuration

Hello,

I am having an issue with Twilio inbound webhook configuration. When I text the number it reaches out to the webhook url given to me by the Twilio integration UI.

In the Twilio Debugger -> POST -> Request -> Message Text

Msg: "Invalid Content-Type: application/octet-stream supplied"
sourceComponent: "14100"
ErrorCode: "12300"
EmailNotification: "false"
contentType: "application/octet-stream"
LogLevel: "ERROR"

In the Twilio Integration UI(in Home Assistant), it says I should configure the content type to be “application/x-www-form-urlenconded”, but I can’t find that setting in Twilio or Home Assistant.

Have you made any progress on this?

I can select the webhook service if I go to Twilio - Menu - Phone Numbers -

select the number you’d like, then scroll down and change the configuration from “messaging service” to webhook…

It doesn’t specifically say URL encoded, but I think this is the option you want. I used that setting for inbound to a service called “Textable”. That worked well until my sms volume began to big down their load times.