Two different versions of hass reported?

I have some performance issues im trying to solve, and doing so shows I have two different versions of hass reported.

pi@hassbian:~ $ hass --version
0.72.1

But the Frontend (about) shows 0.72.3
Is this an issue? Could I have ended up with a partial upgrade/duplicate installations?

Yes, this isn’t uncommon. Users forget to enter the virtual environment before upgrading and end up installing another HA instance.

I would SSH into your Pi and look at what is installed where. the ls command is useful for this. It will report the files and directories for your current location. You shouldn’t see any home assistant folders in the main directory.

1 Like

I found another .homeassistant i Pi’s home directory and deleted it. But the problem persists. hass --version reports one thing and the UI something else.

The reason I believe something is wrong is because the log file is filled with “… took longer than 10 seconds”.
Its everyhing, from API-calls to nmap tracker. The Pi isnt under any load so I dont know whats causing it. Perhaps it has nothing to do with the version issue, or perhaps it does…

To find out how many versions of hass are running do

ps -eaf | grep hass

You should get 1 line like

homeass+  8741     1  6 Aug08 ?        11:29:30 /srv/homeassistant/bin/python3 /srv/homeassistant/bin/hass

The copy of hass that returns the version depends on the PATH environment variable of the user you are running under. To find out which binary will run you use the which command

which hass

For the Pi user that should yield nothing - as the pi user should not have access to the ha binary. You could delete any versions that you find, but if they aren’t running it isn’t necessary. Just make sure you don’t delete the version that is running.

To find out the version that actually runs, you need to switch to the homeassistant user, enable the virtual environment, and then run the hass --version command.

pi@hassbian:~ 
$ sudo su -l -s /bin/bash homeassistant
homeassistant@hassbian:~ $ source /srv/homeassistant/bin/activate
(homeassistant) homeassistant@hassbian:~ $ hass --version
0.75.2

To be specific about the load the Pi is under, try uptime

(homeassistant) homeassistant@hassbian:~ $ uptime
 10:37:42 up 132 days, 16:48,  1 user,  load average: 0.38, 0.39, 0.36

Response time from sensors may be due to network problems, HA configuration or other programs on the Pi, so you need to look at all of these. But it may not even be a problem, depending on how frequently the messages occur.

I have one process runinng:
homeass+ 511 1 9 19:32 ? 00:21:41 /srv/homeassistant/bin/python3 /srv/homeassistant/bin/hass
Its executed from /srv/homeassistant/bin

But which hass referers to
/usr/local/bin/hass
and running hass --version as ‘pi’ I get another version number! Problem solved, excellent, thank you.
I guess I dont need hass etc in /usr/local/bin/hass?