Two identical lights not behaving the same way

I have two identical Sengled Element Color Plus light bulbs (they came out of the same box) which I would like to turn on, setting the color to color name red and the brightness to 10%. I do this calling the Light: Turn on service.

This worked for months until a few days ago when suddenly one of the two lights would not turn on. However, it would turn on by controlling the light directly in entities. The other light continued to work consistently.

By process of elimination, I found that the light would not turn on if I set the brightness, but if I removed the brightness parameter it would turn on just fine.

So my work-around was to turn on the lights with one service call, and set the color and brightness with another.

The work-around is working fine. Nevertheless this seems very odd to me. Had anyone else had this issue? Any thoughts on how to fix the issue instead of working around the problem?


I had a similar problem with my Sengled candle lights. It was opposite for me, I could turn them off, but had to set the brightness to turn them on.

Are you on Z2M or ZHA?

After changing the optimistic option under the device settings in Z2M, everything worked as expected for me.


Ah yes, I forgot to mention my configuration:
Neither actually. I am using a Hubitat Elevation C7 to control my Zigbee (and Z-Wave) devices, and the hacs-hubitat integration to instantiate all of the devices into Home Assistant.