Two or more devices publishing to HA MQTT add-on

Can anyone help? I currently have a remote device which publishes data via various sensors in my YAML config file, to the HA MQTT addon (running on an HA Yelllow box) and all works well. The problems is I have a second remote device which I want to publish to the add-on but the MQTT integration will only let me configure the set up for one device not both. How do I get around this? The second device can be reached through MQTT Explorer on my PC but is on a remote server ( whereas the current device configured within the add on points to my local HA IP address

Secondly, the current device can be reached through HA via WAN thanks to a Cloudflare tunnel or by using Nabu Casa’s HA Cloud (whichever I choose to use), however I also access the device through a couple of Android mobile MQTT panel apps which won’t read the data of the device over WAN (probably because they require an external IP address. I set up the MQTT addon so I could have local access, but I am guessing if I want to access the device through the apps I will need a public broker which I want to avoid or maybe opeining up the ports on my router (again which I would rather not do). Does anynone have any suggestions as to how I can use the mobile apps to see the device and control it over WAN and not LAN (which works fine). Both apps require MQTT connection settings of a DNS broker name or the IP address of the broker and a port number, username and password. They currently use my HA MQTT addon username and password and my HA IP address and port 1883, which as I said work fine over LAN but useless away from home otherwise. As I said I can still see the current device in HA over WAN as it is currently configured.