U-Bolt Pro Z-Wave best lock so far but still a failure

I just purchased one with a Z-Wave USB stick (Aoetec Z-stick 7 Plus) and I’m honestly dissapointed.
You’re able to control the device, by lock and unlock.
You’re able to see the state of the device connection to Z-Wave, and some battery info, although I’ve seen reports that this never updates so we’ll see about that.
Finally, there is a “Current status of the door” which is always Unknown, there is no state for it.

Overall, very disappointing

Thanks, @nowjon! I figured it was very rudimentary.
I guess the current status of the door is that extra open/close sensor they include with the lock

It’s very green, like all the multiple requests that were made for them to have an open API.
The hardware itself has been very stable for me in the past 2 years… it’s the software piece that I’m disappointed at.

What is so disappointing about it? It locks and unlocks, so it’s doing its job isn’t it? Are you expecting other features?

Don’t forget to check for Notifications.

Finally, there is a “Current status of the door” which is always Unknown, there is no state for it.

Have you tried a re-interview?

Yes I have, with 2 different locks without change.

And yes, I would expect that door status with the included door sensor would be shared, but also, if the lock fails to lock I’d appreciate it showing unlocked instead of locked luring me into a false sense of security.

I went to Dev Tools > Event > and pasted zwave_js_notification, but this doesn’t show anything when listening. Either through sending the command through HA or the app.

I’d look at the “+4 entities not shown” in your screen shot and enable these and restart HA. Then look at those entities, one of them may have the info you need.


The above are teh disabled entities I enabled, and after a reboot of the server they all show 0

Manually unlocked the lock and still showed Locked in HA
Hit Unlock, it stayed unlocked
After a few seconds it auto-locked and updated in HA

Verified there was no change to any of the sensors.

Manually unlocked the lock, opened the door
Shut the door, auto-locked

Verified still no change in any of the sensors.

I think maybe if we could get a ESP32 setup to get the Bluetooth info similar to the Smartdry solution here: Clothes Dryer Automations - #130 by bryangerlach we’d be in great shape, just not familiar enough with it to do so myself

I did verify though, that my ESP32 with BLE Tracking does show the locks, so I guess it’s possibe?

[21:10:48][D][esp32_ble_tracker:792]: Found device AC:4D:16:31:8A:8E RSSI=-83
[21:10:48][D][esp32_ble_tracker:813]: Address Type: PUBLIC
[21:10:48][D][esp32_ble_tracker:815]: Name: ‘U-Bolt-ZWave’
[21:10:48][D][esp32_ble_tracker:817]: TX Power: 2

[21:11:03][D][esp32_ble_tracker:792]: Found device F0:5E:CD:C9:3C:77 RSSI=-85
[21:11:03][D][esp32_ble_tracker:813]: Address Type: PUBLIC
[21:11:03][D][esp32_ble_tracker:815]: Name: ‘U-Bolt-ZWave’
[21:11:03][D][esp32_ble_tracker:817]: TX Power: 2

Sorry that didn’t help, was worth a shot,

What is so disappointing about it?

Z-Wave is spotty on the lock and the status sensor is always Unknown.

Are you expecting other features?

No, I’m expecting the reported features to work and work consistently. Pretty simple.


FYI: I was very frustrated about the Sensor Status… But for what it’s worth, however, if you add a simple “Entity” card pointing to the lock entity itself (not the sensor), it properly displays “Locked” versus “Unlocked” for me!

Did you ever get this fixed? Mines including to the network the same way with security set to “none” and nothing is working. I’ve sent an email to U-Tec thinking it was their issue because their app is reporting a security issue when pairing to my Aeotec Z-Stick Gen 5…saying to remove it from the hub because of a security error. It (The U-Tec app) never asks for the 5 digit code on the battery cover of the deadbolt as I was expecting during the inclusion. I do have the security keys installed and listed in the Z Wave JS add-on. Other than integrating with HA, I’m very pleased with this lock!

This lock continues to be a PITA. I love the hardware. But their software execution is terrible. I’ve got the hub (which is silly it’s a separate purchase), and connecting to the lock remotely is still terribly unreliable. I do not recommend this lock unless your family is never going to access it remotely (aside from the lock and unlock feature throw HA).

I still can’t get it to pair, with security. I’m wondering if I need zwave js & MQTT, or if my Aeotec hub is just too old, or if this has to run through smartthings, Alexa, or ring etc…obviously people in this thread @nowjon have gotten it to pair with security. My question is simply, how? If anyone knows, can you chime in and help a brother out? U-Tec support has gone off the radar.

I’m running into the same issue as you @trailheadmedia - I get security errors. I thought it might also fix it to switch over to zwavejs2mqtt (now just called Z-Wave JS UI, just in case that caused any confusion). Unfortunately, that made absolutely zero change other than telling me that there was no security configured which I assume is the issue. Excluding it and re-including it has not made any change.
Anyone else have suggestions? I am thinking about forgetting about the z-wave functionality all together and just getting a wifi bridge that it could connect to and try and add it that way to HA.
Anyone had luck with that or getting security to work?

I have had the u bolt pro zwave in place for almost 2 months. Hardware is excellent. the status of the door = unknown is because the built in sensor won’t work with steel doors. I use the zooz ZSE41 as a working door status sensor and it works great!! I have an automation that will lock the door 30s when it is detected closed (zse41). the automation also unlocks when detected open (to save the door frame from bolt damage). My issue is that occasionally the lock when manually unlocked does NOT report that to HA. which means it doesn’t lock again with the automation. it also means I look remotely at the lock and it shows locked when it isn’t. The zwave connection is secure S2 Access Control. I keep looking for a fix for this. my zwave stick is ZST10-700 with firmware: 7.17.2. Note: when the lock is in an unlocked state and HA says it is locked, the APP shows it as unlocked. In that ‘wrong’ state, a re-interview and HA gets the proper state of the lock.
UPDATE: reading the ULOC web site, one of the help items (reading between the lines) said low batteries may yield poor communications. Even though the battery said 100% it was the batteries shipped with the lock. I replaced them. I have NOT had the communications issue since (3 weeks). YEAH!!! great lock! (battery sensor is spaced)


Same exact problem here.

I’ve paired it at all 3 security levels (it fails to pair at S2 even with the proper 5 digit code).

Did you ever get this working? Anyone?

Yes, I got it to work with zwave2mqtt.

1 Like

Thanks for the reply!

I finally got the Lock to work after about 20 tries.

I am planning on switching to the mqtt from the JS. Is there a reason why the lock would pair with mqtt and not JS?


Don’t think so.

Both the official addon zwave_js · home-assistant/addons (github.com) and the community addon Z-Wave JS UI - Home Assistant Community Add-ons (github.com) are using the same Z-Wave JS Server as the backbone.

As of today they both run the same server version, so the only main difference is in the UI.

So if you want to switch, getting to the UI should be your main reason. Other than that the motivation diminishes.

1 Like

Thanks for the reply.

I am trying to set up the JS UI but it is not seeing my hub on the serial port…so digging into that now.

It appears there have been some improvements to (most likely) home assistant.

Now I’m getting the Lock and Unlock status, and it updates fairly quickly, around a second of delay which is fine, as well as the door status!

I think it’s actually a useful piece of hardware now!

1 Like