Ubiquiti Unifi direct AP login problem


I’m configuring Ubiquiti Unifi WLAN AP to work as a device tracker. But my problem is that I’m not able to get home assistant to login to the AP when setting up the component. In HA logs it says “Password refused” and when I checked the logs from the AP it says that there are three attempts to login for “non-existent user”.

I have created a new user for home assistant and that works when trying to login from computer. I have also tried admin user but that also fails to login. Is there some trick that I do not know? The password does not contain any special chars and I have tried with ’ ’ and without.

Here is my config:

  - platform: unifi_direct
    host: IP
    username: 'username'
    password: 'password'

Of course now I was able to get it to login but only as the admin and I do not want that. Has anyone any tips on why it might be that the home assistant user is failing? The password is 27 chars long.

So if you manually use the terminal to ssh to the access point with that user does it work?

I played around and noticed that only the user that is configured in the “Device authentication” part is able to use ssh. That might be the reason that it was not working.

I am just worried that what rights this user has…

Answering myself, it is root. Not good at all… Might try to change the controller version. But as I do not have the controller running, I was looking to run it on my HA installation.

Or sonce the AP is in different VLAN, I could just limit the access to that port. Any ideas?