Ubuntu Upgrade Killed Everything

Tags: #<Tag:0x00007fc418c1a118>

Hi folks,

The NUC I use to host hassio is also used for other smaller projects related to home automation. Today I upgraded Ubuntu from 18.04 and 20.04 and something went terribly wrong.

After rebooting hassio was out. A sudo docker ps showed me that only homeassistant and hassio_oberver where there. A sudo docker image ls also showed me nothing. Eventually I realiased that I screwed up docker installation at some point, so I installed docker-ce and portainer and I was finally able to successuflly start hassio (it installed all other hassio_* images required).

The problem is that my addons are gone. They are grayed out and if I try to run them, I get an error:


404 Client Error for http+docker://localhost/v1.41/containers/create?name=addon_a0d7b954_nodered: Not Found (“No such image: hassioaddons/node-red-amd64:7.2.11”)

I understand what’s going on, but I have no idea of how to fix it. I could simply uninstall and re-install, but all my configurations would be gone. Do you have an idea of what I can do to manually add them back or at least extract the important configurations from it?

Cheer!

Same thing happened to me. I was unable to start the addons and had to reinstall them through the Supervisor.

1 Like

You’re not running hassio. For starters, that name was deprecated back in June in favor of Home Assistant OS … which is not what you’re using. You have Home Assistant Supervised on Ubuntu.

Your installation may be affected by this:
Docker 20.10 not compatible with Supervised installations

4 Likes

Thanks for educating me. Indeed I say “hassio” wrongly just for the sake of convenience. And thanks for the link. Indeed downgrading was exactly what I did and fixed everything. Now I’m trying to recover my addons…

If you are working on your OS, you might as well go to Debian - I think that on Ubuntu you’ll end up in an unhealthy state sooner or later:

Unhealthy state - Configuration - Home Assistant Community (home-assistant.io)

I think it is supervisor reporting it and consequence is you will no longer be able to upgrade HA nor add-ons.

I moved from Ubuntu to Debian on a NUC yesterday because of this. Glad to see you sorted out your issue, I thought moving to Debian was the only route left to us.

Jhh

1 Like

I agree @jhhbe and I plan on migrating everything to Debian eventually. Any tips on how to do a headache-free migration? :smiley:

  • I intend to get an SSD.
  • Make a snapshot before pulling out the existing hard-drive.
  • Install Debian 10 and Home Assistant Supervised as per kanga_who’s instructions here.
  • Set host name to what I had previously.
  • Restore the snapshot.
  • If something goes terribly wrong, I can simply put the original disk back in (so everything keeps working while I scratch my head trying to figure out where I went wrong).
2 Likes

Well this teaches me two things, dont do auto updates and look here before I give up and reformat my machine :slight_smile:

I was using Linux mint 19.3 and after giving up because of this problem and deciding to upgrade to Linux mint 20 I stumbled on to the problem while looking for a guide to reinstall.

See here: Installing Home Assistant Supervised on Ubuntu 18.04.4

I guess im venturing in to debian. That still works, right?

1 Like

Indeed debian 10 is the only supported OS to install supervised on.

1 Like

hi,

@123 summarized it very well. I used the ssd I had, so no fallback but the NUC was rather empty with everyting being docker.

I ran a livecd on SD card and installed from there, regular install from SD kept searching for a CD/DVD which it couldn’t find

At onboarding you can upload a previous HA backup - the NUC is my secondary instance and runs only zigbee2mqtt, so backup was only 4MB. That kept hanging but in portainer on my primary install on an RPI4 I could see all containers being created on the NUC. After a while I took a chance and rebooted. One re-install later over that one it worked though I can’t reconstruct every step.

I would also store compose file on github, I run portainer on my main RPI instance and then deploy github compose stack on the NUC and some other RPIs. That works really well.

For me it is the answer to what HW should your HA run on? I think RPI has most support so primary is an RPI4 with SSD and not too many additional containers: google backup, influx, grafana, esphome, DSS voip notifier, duckdns, caddy, file editor, samba, simple scheduler, mqtt broker, portainer.

On a PI3 that was too much so I ended up getting a NUC for Plex, Nextcloud, Photoprism, Synthing which is also running on an old RPI3B+ (ex HA machine). I struggle a bit with file permissions between Nextcloud and Photoprism but that is just me.

I agree that you don’t want to waste an entire NUC on HA, but also I think tinkering with the machine that has your main install on is not a good idea so that’s why I split.

Jhh

Same happen here. Everything was killed. I’m lucky that i have a snapshot that i made 2 days ago. Now i realize how important is my home assistant for me and my home

@rafaborges you have ubuntu, like me.
Try this commands, then reboot, and then make a restore of the last snapshot of home assistant that you have

apt install containerd.io=1.3.9-1
apt install docker-ce=5:19.03.14~3-0~ubuntu-bionic
apt install docker-ce-cli=5:19.03.14~3-0~ubuntu-bionic

You have to be careful to not to update your ubuntu, until this has been fixed

i have my home assistant working again, but i had to make that snapshot complete restore, since some containers like node red had been disappeared. Once you make the complete restore, you will have everything working again

1 Like

Just had very similar on Ubuntu 20.04.

If you try and start each addon you can grab the image name for the container from the error that appears, or the error in the supervisor log, then pull it manually from the base OS and that seems to work, just make sure the version matches.

Thank you, everyone!

Just a final update on it: I decided to scrap the Ubuntu server, install Debian and start from fresh. I know there are some ways to do it properly, but it was way easier to start from scratch.

Thank you for your help!