Unhealthy state

Help!
I get these error messages when I boot the host system:
WARNING (MainThread) [supervisor.resolution.evaluations.base] NetworkManager is not correctly configured
CRITICAL (MainThread) [supervisor.core] System running in a unhealthy state and need manual intervention!
WARNING (MainThread) [supervisor.jobs] ‘HomeAssistantCore.update’ blocked from execution, system is not healthy

It’s impossible to upgrade to 0.118.5
I’m on Debian 9, Intel NUC, HA Core 0.118.3, and it’s impossible to upgrade.
The supervisor is version 2020.12.6, upgraded today.

1 Like

Similar issue, but on Ubuntu 20.04.1. On 0.118.4 trying to get to .5. Supervisor doesn’t load now. Guess I should not have upgraded Supervisor.
20-12-05 21:28:15 WARNING (MainThread) [supervisor.resolution.evaluations.base] Detected unsupported OS: Ubuntu 20.04.1 LTS (more-info: https://www.home-assistant.io/more-info/unsupported/os)

20-12-05 21:28:15 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete

20-12-05 21:28:15 INFO (MainThread) [main] Running Supervisor

20-12-05 21:28:15 WARNING (MainThread) [supervisor.core] System running in a unsupported environment!

20-12-05 21:28:15 CRITICAL (MainThread) [supervisor.core] System running in a unhealthy state and need manual intervention!

20-12-05 21:28:15 WARNING (MainThread) [supervisor.core] Ignoring Supervisor updates!

2 Likes

Same here.

I’m seeing this:
Screenshot from 2020-12-05 16-53-27

The unhealthy part is this (Supervisor is not privileged):

Screenshot from 2020-12-05 16-54-18

Which leads me to this page instructing me to re-run the installation script. Hmm, hold that thought.

Elsewhere in the log there’s this error message informing me that the installed version of Network Manager (1.10.6) is not supported:

20-12-05 21:22:56 ERROR (MainThread) [supervisor.dbus.network] Version ‘1.10.6’ of NetworkManager is not supported!

A warning message contains a helpful link explaining the issue:

20-12-05 21:23:04 WARNING (MainThread) [supervisor.resolution.evaluations.base] NetworkManager is not correctly configured (more-info: https://www.home-assistant.io/more-info/unsupported/network_manager)

It informs me of the following:

The current minimum supported version of NetworkManager is: 1.14.6.

However, Ubuntu informs me that my instance of Network Manager (1.10.6-2ubuntu1.4) is the latest version:

~$ sudo apt upgrade network-manager
Reading package lists... Done
Building dependency tree       
Reading state information... Done
network-manager is already the newest version (1.10.6-2ubuntu1.4).
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Not sure re-running the installation script will do much good if the latest version of Ubuntu’s Network Manager happens to be lower than what Home Assistant requires. :thinking:


EDIT

Overlooked to mention that the system was dead when we arrived home today (dark house; no lights). No browser access. Logged into the server and restarted it. Home Assistant took longer than normal to get back on its feet. First FUBAR in 2 years. Not kidding when it said it was ‘unhealthy’. :wink:

Perhaps you are running into a real consequence of ubuntu being unsupported for supervised?

1 Like

Is that the case for debian 9 as well?

In my case, I have a watchtower container in my instance. After I removed that container and rebooted, I was able to run the update. Finally, I re-installed watchtower after the update.

Debian 9 - stretch is not supported. Debian 10 - Buster is

1 Like

I ditched watchtower as it will cause your installation to be unsupported (even if it doesn’t touch ha containers)
I switched to Docker-compose and a cron job to run that twice a day. Same result but supported.

1 Like

Possibly. I’ve been meaning to switch to Debian to avoid this kind of ‘creeping breakage’. Everything was working perfectly which lulls you into thinking ‘this unsupported thing ain’t so bad’ … until now.

Great suggestion … I’ll try that

Ookay… Is it easy and straightforward to go from 9 to 10, or can I expect hours and days of agony?

Dist upgrade for Debian is pretty simple and fool proof…

1 Like

my debian 10 has this version:

[email protected]:~$ apt policy network-manager
network-manager:
  Installed: 1.14.6-2+deb10u1
  Candidate: 1.14.6-2+deb10u1
  Version table:
 *** 1.14.6-2+deb10u1 500
        500 http://ftp.nz.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

Not sure how this divide can be bridged. It will forever complain about Network Manager’s version unless Ubuntu bumps it up a few notches overnight. :man_shrugging:

~$ apt policy network-manager 
network-manager:
  Installed: 1.10.6-2ubuntu1.4
  Candidate: 1.10.6-2ubuntu1.4
  Version table:
 *** 1.10.6-2ubuntu1.4 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.6-2ubuntu1.1 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     1.10.6-2ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

So what version of ubuntu are you on?

It’s version 18.04.5 (see screenshot in my post above).

Is it possible to add the Debian sources to your /etc/apt/sources.list and then update that way? I’ve never tried, but might work?

deb http://deb.debian.org/debian-security/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

This “unhealthy” thing is only affecting Supervised/OS installs, correct? I don’t see how it could break a Core install?

Trying to see if the next update to v119 is going to be an issue for me. I’m on v118.4 and I never do .x updates unless something is broken. Right now everything is fine.

If this is by design then it seems as this new functionality should have been listed in the “breaking changes”. Things seem to be getting a little heavy-handed.

I actually feel bad now that I just told someone in another thread to not worry about the “unsupported” message since it won’t affect anything. Oops.

Sorry I missed that, I wonder is ubuntu 20.04 ships the right version of network manager?

Normally I would say ‘Worth a try’ but this is my production system and I try to avoid using it for experiments. Unless someone can confirm that system stability is guaranteed, I can’t chance it.
(Having said that, it’s not exactly stable in its current state … )

I have it running on a spare laptop. I’ll fire it up tomorrow morning and check.

1 Like