Udev issues

Hello, hoping someone can help me out. I’ve been trying to create udev rules in hassbian all night and failing miserably…

this is what my /etc/udev/rules.d/99-usb-serial.rules looks like
SUBSYSTEM==“tty”, KERNELS==“1-1.5:1.0”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“8a2a”, SYMLINK+=“zwave”
SUBSYSTEM==“tty”, KERNELS==“1-1.5:1.1”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“8a2a”, SYMLINK+=“zigbee”

Below are links to the udev details for each device
zwave: http://pastebin.com/L0YJL0Bm
zigbee: http://pastebin.com/sTiP6444

ls -al on rules.d shows
-rw-r–r-- 1 root root 983 Mar 21 2016 99-com.rules
-rw-r–r-- 1 root root 217 Feb 11 07:52 99-usb-serial.rules

so i don’t think it’s a permissions issue…i’ve tried various attrs settings including ATTRS{interface} and nothing works!

please help, thank you

1 Like

I too have been having issues here with the same device, can anyone chime in?

HASSbian doesn’t seem to be working anymore, tried several times for the past day. Nothing on the logs… homeassistant doesn’t start

I have no issue starting it, I can tell you that using hassbian.local URL did not work for me. The issue I’m having is mapping a device using a udev rule

@Plunder: The exact entries for the 99-usb-serial.rules file are not obvious. This is what I use for my Aeon Z-Stick gen 5:

SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ZStick"

I see from your udev details that the devices are very similar; same idVendor and idProduct; which I use to identify my Z-Stick. Perhaps you could use the value of


to differentiate your devices instead of the KERNELS attribute.

Good luck with this.

Edit: Oops, I see you have already tried the ATTRS{interface}.

The other thing that I noticed is that the new alias did not show up until I unplugged the device and then plugged it in again.