UI not reachable, ssh connection refused

Hi there,

maybe it’s a dumb question, but:

  • nothing was changed from my side on a running HA
  • i got an xx.js-error displaying the supervisor page in the UI recently, everything else worked.
  • tried a reboot through the UI - did not reboot
  • took off the power of the pi, turned it back on and cannot connect to the ui at all
  • tried to ssh to the pi - get an “connection refused”. The pi is having a red led constant on (after some red/green flickering what happens after repowering, network is flickering and i can see the ip in the network

Some idea what was/is happening here? And more importantly, what i can do about it?
Thank you very much in advance!

Can you ping the IP?

Yes, i can ping the IP as well as “hassio.local”.

Ok, then I’m out of solutions. Besides getting a different sd card putting a fresh install on it and restoring a snapshot. Sorry.

Thank you anyway! :slight_smile:
I am hoping to get around this… Perhaps someone has an idea.

Ok, i managed to connect a screen and a keyboard to the Pi.
i can see a lto of lines of information and at some point i’m asked to login.

Welcome to Home Assistant
hassio login:

Is this login using the credentials i use, when i normally login as a user via the UI?
Because it is telling me, the login or password is not correct.


This login should be ‘root’ and no password.

If you haven’t already solved the problem or set up a fresh HA:
When you’re in this CLI, running ‘core check’ might help.
From the description it should only check the core configuration, but running it solved an unavailable UI for me once.

Thank you, eventually got to this point.
Checked, updated and checked again to no avail.

I decided to go the extra step and set it up as a new one and copy things from an old backup i had. This way i got rid of a lot of old and now useless stuff… Maybe it was for the better. :slight_smile:

No problem!
Good to hear that you got HA running eventually, even if it had to be a kind of fresh start :smile: