Ultra slow system

Hi there

I’m all new to this thing (home automation in general), but have watched a lot of videos from mostly BRUH Automation about HA, Hass.io and Raspberry.

I’ve installed hass.io on my Raspberry B+ (old one I know, but should work, right?), with Sandisk Ultra 16GB.
I’ve finally got my z-stick working after several reinstallations and a lot of patience.
Now I’m trying to set up device tracking, but the known_devices.yaml file doesn’t get created. The log says that it can’t access it, so at least it’s trying something.

In all of my restarts, i’ve noticed, that the server is unreasonably slow to start. In the log there is 8 or 9 minutes between “Home assistant stopped” and “Home assistant started” :open_mouth: is this normal?

I can also see in the log, that it’s trying to load Logitech Media Server add-on, and it’s taking to long (just like all of the other setups), so I guess the system is psychic, as I’m planning to install this add-on, but haven’t yet (?)

I hope you can help this noob.

Thanks in advance

disable discovery and see if it helps. I find that the discovery component causes problems for me.

Also, if you’ve been running for a while the db can get really big and slow things down. You can purge it by using the service calls (bottom left of the web interface). Domain = recorder, service = purge, data = {“keep_days”: 1}.

You can also configure the recorder to auto-purge after so many days, you can view the component documentation to see how to configure it.

I can’t believe the db should be “full” - the system got installed yesterday.

I tried to disable discovery and restarted - it didn’t do anything about the startup time:

21.32 Home Assistant started
21.31 yr Symbol changed to 1
21.23 Home Assistant stopped
21.20 I hit the restart-button

But the known_devices.yaml now exists and there is nothin about the Logitech Media Server in the log.

Just made another restart:

09.30 Home Assistant started
09.30 Morten is at home
09.29 yr Symbol changed to 15
09.13 Home Assistant stopped
09.09 I pressed restart

Isn’t there any extensive log where I can see where it hangs?

home-assistant.log looks like this:

2018-01-06 09:26:24 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=8 from 2018-01-06 08:17:44.254464)
2018-01-06 09:26:43 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.
2018-01-06 09:26:46 WARNING (MainThread) [homeassistant.setup] Setup of device_tracker is taking over 10 seconds.
2018-01-06 09:27:17 WARNING (MainThread) [homeassistant.setup] Setup of tts is taking over 10 seconds.
2018-01-06 09:27:51 WARNING (MainThread) [homeassistant.setup] Setup of zwave is taking over 10 seconds.
2018-01-06 09:29:28 WARNING (MainThread) [homeassistant.components.sensor] Setup of platform yr is taking over 10 seconds.
2018-01-06 09:58:25 WARNING (MainThread) [homeassistant.components.device_tracker] Updating device list from nmap_tracker took longer than the scheduled scan interval 0:00:12

Thanks, I’ll give it a try.

I don’t know if any of you guys can get something out of this, but to me it just seems like everything is incredibly slow.

The first log is from I hit the restart-button and until it was cleared, and the second is after it came up again

As you can see there’s 5 minutes from the last post ind log1 to log2 starts - there’s nothing in between that.

Could it be the SD-card that is crappy, or any hints to how I can test read/write speed on the card from the pi?

Well, I tried to install Hass.io on a Raspberry 2 I used for mediacenter, and it is a huge difference in speed and responsetimes. So now I have ordered a Raspberry Pi 3 to use for Hass.io.

Thanks for your time.