Unable able to add IPP network printer

Hi –

I got a HP HP LaserJet Pro M118-M119 Lexmark E120N and both support IPP and it is enabled on both, but I can get neither setup correctly.

What I am not sure is what I need to put in for the relative path to the printer. I keep trying different combinations for host using the actual host name and IP address, but ditto.

Suggestions appreciated.

So you’ve tried this format: http://PDG’s IP:6310/PrinterOnPrinterName

which would translate to: for example

I tried this and keep getting unknown error:

If I type the printer webpage opens

You have check boxes to use SSL, I believe you need to use https:// then.

I have tried with and without having those boxes checked. Continue to get error.

I have hp printer and it’s network printer. For me connecting printer with lan cable to a router was enough as i remember. Ha integration found the printer.
Maybe you should check your local printer setup and printer setup.
If your printer is not set up to be network printer ha integration will not find it.

If you choose to click the use SSL certificate option, then you need a FQDN and not an IP address.
Certificates do not work with IP addresses.

Secondly if you use a hostname, then you might end up trying to connect to your public facing IP from inside your own network and then you might need a NAT loopback/hairpin setup in your router.

Hello @ddaniel and @WallyR

Thanks for replying. @ddaniel - Printer is on a wired ethernet connection. @WallyR I can specify a FQDN if that is what it takes, but does that go on line 1 or line 3 from my screenshot above?

Thanks again guys.

I have never set up the IPP print integration in HA, but I would guess that goes on the first line and the relative path should be like in the first screenshot.

In your case i will go to basic. I don’t know what os are you running but if printer is properly configured on os level than ha integration will find it automatically.
You are trying to add printer integration but it doesn’t work. This is probably because your printer for some reason is not properly set up in the first place.

Home computer is running Windows 10 Professional. The computer was bought from CDW and it was not pre-loaded with the typical bloatware you would see if buying it from a Best Buy or other retailer selling OEM builds. I can print to my printer via its TCP/IP addres, its pingable and I can reach the printer’s home page. In fact if I uninstall and reinstall the printer software when I specify the IP address it has no issue connecting to it prior to installing the driver. So what leads you to believe printer is not setup correctly? Let me take this a step further. While the printer is on a different vlan, if I switch my home computer to that vlan no issues and I am reasonably sure my vlans are set up correctly using Ubiquiti. Also the Lexmark printer which is extremely basic black and white printer cannot be found either. I appreciate Home Assistant and it integrated my Lextron Caseta setup perfectly, I sometimes am hesitant with open source and lack of support.

Not to say I don’t appreciate the efforts here which I do, but hopefully this post shows you I am not a total novice here.

Unfortunately I don’t see any other way to manage my printers in HA, otherwise I would use a vendor integration. In that case one from HP or Lexmark. To say Lexmark does not have HA integration is not surprising. What is surprising is HP does not have one.

I dont use windows on any of my personal computers. I can show you why printer integration is working on my side. If I do

netstat -tunlp | grep 631

this is what I get

(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp        0      0 *               LISTEN      -                   
tcp6       0      0 ::1:631                 :::*                    LISTEN      -                   
udp        0      0   *                           -  

So you can see that on os level I have working ipp. Home assistant ipp integration is just using my system setup. That is why I think that you printer is not properly set up on os level.
I don’t know about windows, I don’t use it except when I have to use it and basically don’t care about windows setups.
Or I can do

sudo netstat -tunlp | grep cups
tcp        0      0 *               LISTEN      618285/cupsd        
tcp6       0      0 ::1:631                 :::*                    LISTEN      618285/cupsd        
udp        0      0   *                           618294/cups-browsed 

I use this integrations for my HP LaserJet M277.

I am reading up on that now and the chat on this is quite long. Being able to see my printers is a nice to have not necessarily a must have as I can go to their respective home pages. I am still really new to HA and have little to knowledge of YAML We’ll see where this road goes. Again nice to have, not must have. thanks.

Hi –

Wanted to revisit for a moment. I got Rmcard205’s and my Lutron Casetta working in HA. They are all on the same subnet as (192.168.10.x) that HA is on. My pc is on a different subnet than the above mentioned, but I can still ping these devices, including the printers which are on the same subnet as me (192.1682.x). Does the printers have to be on the same subnet as HA?

No they do not have to be. That being said if you are using VLANs they will also communicate across VLANs and subnets. The only thing that would stop that is if one is blocking it with a firewall rule or rules involving VLANS and then the subnets.