Unable setup learn command. Failed to call service remote.learn_command. Unknown error

Hell there,

I just added Broadlink RM4 IR/RF hub to my HA. Trying to make it learn to control my RF remote that controls the roller blinds. But it fails at the first step when I press the ‘Call Service’ button with the error ‘Failed to call service remote.learn_command. Unknown error’. I cannot figure out what is the issue here. Can someone advice please?

I added Boadlink as a entity but it’s the same error if I add it as a device

If I select ‘ir’ for the command type, it does not show any error. But my remote is a RF remote

I have the same problem with learning. Did you try a different remote? I tried the RF remote of my fan and that works. But I have a RF remote for my wall lamps, that doesn’t work, I get the same message

I have solved it! Considering your post is from today, you did a Home Assistant Core update like me today. I reverted back to the back-up before the update and it works now

1 Like

Thanks @LazeX7. This solved my issue!

1 Like