Unable to acess HA

Can someone help me get back into my HA?
I am using a Dell thin client to run HA.
I was trying to sort out my config.yaml, checked with developer that HA would restart which it said it would, but now it won’t. It is logged in to my router on the correct address, but I can’t get access.
When I try I get " The connection was reset
The connection to the server was reset while the page was loading."
This happens on both my macbook and my PC.
Have tried "ssh root@ (ip address) but get connection refused.
If I try on my table I get “this page is’nt working, {ip address} did’nt send any data”

I mainly use HA to run my solar panel system using predbat.
I think that HA and predbat are both running because if I check the solar system with a seperate givenergy app the battery is charging and then discharging as it was scheduled to do with predbat.

Just checked and I can ping it. Not sure what to do next.

Can you attach a keyboard and monitor to the Dell?

Can attach a keyboard, not sure about a Monitor, should be able, but will check

have got them both attached, but no signal from monitor so not sure if its connected ok., or if I have to do something to enable it.

You don’t have to do anything to HA for it to show, you could try powering it off then back on again with the monitor attached and if you don’t see everything loading then your monitor or cable may be problematic.

that got it showing. I now have the ha command line screen

Also Home Assistant observer reports


At the console type info, what is the state?

Not sure, the display is clipped, its not displaying the first few 2 or 3 characters.
I’ve tried adjusting the monitors zoom but its the same, so it must be a HA problem.
However if its just above the operating system info line its says running.

It’s pure ascii text, it’s most likely not an HA problem if it’s clipping.

So if it’s running then it thinks it’s happy, you may have a corrupt config or system. Do you have a recent backup?

This is what the problem is likely to be. Dev may have said it would restart but if you removed key configuration options then it would say that but you might still be unable to get in.

yes I have a 2 day old backup

Everything points to HA being OK but your config might being bad, I would look at restoring. I always back up offline when making major changes (in addition to automatic off-machine backups nightly) because you never know when your changes are going to break your house’s brain :slight_smile:

1 Like

Might be able to restart HA in safe mode:

ha core restart --safe-mode

Then do a restore:

Common tasks - Operating System - Home Assistant.

1 Like

Except when connected directly, the ha is superfluous there (but will still work with a comment that ‘ha’ is not needed).

Thanks! Forgot about that.

Have managed to reset password, but still cant get in. Have tried a browser I’ve not used ha on before, can I log on from the command screen?

No, but from your original post it sounds like it’s not a password issue unless you forgot to mention it only errors out when you attempt to log in rather than when you attempt to open the page.

thanks for your help. Looks like it’s a restore then. Will read up how to do that.