Unable to add esp devices


I’m quite a newbie in HA and I wanted to start by adding some ESP32 for data collection (water meter)

I already add ESPHome in HA but when I want to add a ESP32, a have this message :

I tried to use the ESPHome web interface with limited success.
My ESP is well discovered by HA in device page but nothing appear in the ESPHome interface

Do you know why I have this error message "request not successful (500) ? It’s a fresh installation of HAOS on a raspberry 3b

Thanks for your help


Your esp device seems to be already flashed with esphome. You need to place it’s yaml config in /config/esphome/

Maybe this can be of help:

I was getting the “500” error until I created an empty “esphome” directory under /config on my HomeAssistant server.

In my case, I was then able to create and flash over USB a new device – so slightly different to you as yours seems to be already flashed, but I think it might then let you add your existing device as well.

You saved my life :wink:
I spent hours and hours yesterday night to try to make working this f… esp card.
Simply solved by a folder creation. Still not understand why this folder was not created during the installation of ESPHome.
Many thanks

/config is there well before you install any addon.

Yes the solution is to use a File editor in HA the /config/eshome directory and it solved the problem, may thanks i spend days and hours trying to find a solution. Thanks again.

1 Like

Thanks for the solution. Adding esphome under the config folder worked. First had to install the depreciated “terminal” add-on. The new “terminal” does not work. The old one only appears if you set a configuration for yourself as an advanced user that allows installing depeciated add-ons. This took me hours and hours to figure out.

Hi. Have tried for days also… reinstalling ect…

Till find this post about dir… lol so easy fix.

I used Terminal & ssh add-on.
cd config
mkdir esphome


None of this is possible to do unless you run HA-OS.
Does anyone have a solution for us that runs HA Core in a docker container?

Solution to what? What exactly is your error?

The error is ;

Request not successful (500)

But the solutions outlined in this thread works only if you run HA-OS.