Unable to add Google Calendar integration

I’ve followed instructions on https://www.home-assistant.io/integrations/calendar.google/, obtaining Google client id and client secret, then adding the following to configuration.yaml:

  client_id: !secret google_client_id
  client_secret: !secret google_client_secret

When I click Check Configuration button in HASS the button keeps spinning (nothing in browser console). If I try to restart the server from HASS it does not do anything (does not restart). Nothing in the HASS log.

As soon as I remove google: section from configuration.yaml everything gets back to normal - config validation and restarting works.

I’m running Home Assistant 0.114.1 (Docker, supervised)

Is there anything I’m missing?

Yes, me too. Even if you add google: alone in the config file, it just spins during the check. No errors in log.

Has anyone got an update on this? I had google working fine earlier, but I’m having the same issue now.

I got mine working, I believe this was the issue for me:
Google calendar - problem with authorize - Configuration - Home Assistant Community (home-assistant.io)

I did not push Publish app. Not sure if that was in the step by step instructions.

I am having the same issue. Infinity spinning, It looks like is not resolving the promise.
I can’t see anything in the logs. I wonder what is the issue.

I’ve tried to add a test user, tried to publish the Google API, nothing…

It’s really strange.