Unable to Add Network Storage

I have HA running on a Raspberry Pi4. I recently switched my server from Windows to Linux Mint 21.2 Cinnamon. Unfortunately, I am not familiar with Linux and I’m learning as I go. I’m trying to have HA backup to my Linux server but I keep getting the same error message.

Mounting HA_Backup did not succeed. Check host logs for errors from mount or systemd unit mnt-data-supervisor-mounts-HA_Backup.mount for details.

I have looked at some logs on the Linux server but I don’t know if it is the right one. I also am not sure how to find “systemd unit mnt-data-supervisor-mounts-HA_Backup.mount”

I have Samba running on the Linux server and it is working properly. I am able to connect to it from a Windows 10 machine.

Linux Server
Samba version 4.15.13-Ubuntu

I am just not sure where to go from here.

I can’t solve your mount problem, but you state in the description you want HA to backup your Linux server and that isn’t what this network storage function does in Home Assistant. It backs up Home Assistant to the external share you are mounting, not the other way around.

The remote share does not look right, what did you call the drive in the smb.conf file?

It will be the same name that windows connects to.

I forget the steps taken to change it, but my external backup share address is listed as the
[IP]:[Share folder name on NAS]

If that helps?

This is what I have for the folder in my smb.conf

comment = For Home Assistant backups
path = /mnt/Disk_14/HA_Backups
read only = no
guest ok = yes

I am able to connect to the HA_Backups folder on my Linux machine from my Windows 10. The path I type in is \Mule2\HA_Backups

I changed my options to the IP address to the name of the server but I still receive the same error message.


I placed under Remote Share but unfortunately, I still received the same error message.

I have also been trying the NFS option but I still receive the same error message.

I was able to get my network drive connected. Both @Arh and @bob.t were correct.

The Remote share path was wrong. For some reason kept placing the server name or address in the Remote share field. All I needed to put there was the Samba share folder name [HA_Backups]. Once HA accepted the correct address/path, it is displayed as


1 Like

May that be your biggest headache. For a few minutes, anyways.