Unable to add rtsp camera even link are fine in VLC

I have some ezviz in my hometown, which is connected to a different network with my homeassistant server. I created the ddns and forward port, then I can use this link to stream the camera anywhere


I tested the link above in VLC with cellular and also other wifi network, they all fine. However when I use these link for configuring a generic camera within home assistant, it’s not working (connection timeout)

If I use public ip instead of ddns, it shows a corrupted image.

I also noticed that if i choose any of radio button in rtsp transport protocol, it will also got time out issue

Use this to see if your model is listed with the available options. I cannot say why it works in VLC and not otherwise, but additional stream parameters may be needed.

1 Like

Yes my model is C6N and C6CN, they are available in this ispy website but non of the link there worked.

Which brand?

In our screenshot, which protocol are you using?

Are you sure you shouldn’t be basic auth (instead of digest)?

They’re from EZVIZ, as mentioned. I’ve also tried the basic auth, and all 4 protocol but they all go timeout event with the public ip

As with public ip && digest auth && not select any protocol, I can get a corupted image so I think they’re maybe correct.

I have seen another post that the ffmpeg library on home assistant is different/missing something, but I miss that post’s link. So I tried a same code that grab a frame from rtsp stream using cv2.VideoCaptured(). It worked on my other ubuntu server but not on homeassistant

I think you’re on the right path here.

Some years ago when still running HA on a Pi, I had to custom compile ffmpeg for it to work.

What happens if you open the stream with ffmpeg on HA from a terminal? It might tell you what stream error it’s getting.

Right, your very first sentence of the first post. :+1:

1 Like

Was this ever solved?