Unable to add Zwave nodes


#1

Hi
I’ve set up a HA install when I received all my shutter modules (Fibaro FGR 222) so I can include them in HA before we move in our new house, done without issues (controller is a Aeotec Z stick Gen5). A few months later I started working on the real installation, with 2 modules, worked fine but had some issues with HA and so I installed from scratch a hassbian install on a RPi.
Since then I have some trouble with adding new or recognizing modules already associated.

Out of options, I removed all the nodes, reset the Z stick, deleted the zwave files (pyozw.sqlite, zwcfg_0x…xml etc) and started from scratch again, but not luck…
In the OZWlog.txt it seems the adding node mode starts but nothing happens, and then if I hit “cancel command”, then several lines appear, but obviously no new node appears in HA…
Here is an example, waiting 3 minutes between hitting add node (17:05) secure and cancel command (17:08).

2018-12-26 17:05:43.510 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:

2018-12-26 17:05:43.512 Info, contrlr, ADD_NODE_STATUS_LEARN_READY

2018-12-26 17:05:43.514 Detail, Node001, Expected callbackId was received

2018-12-26 17:05:43.516 Detail, Node001, Expected reply was received

2018-12-26 17:05:43.517 Detail, Node001, Message transaction complete

2018-12-26 17:05:43.527 Detail, 

2018-12-26 17:05:43.528 Detail, contrlr, Removing current message

2018-12-26 17:05:43.530 Detail, Notification: ControllerCommand - Waiting

2018-12-26 17:05:43.542 Info, WriteNextMsg Controller nothing to do

2018-12-26 17:08:53.199 Info, Cancel Add Node

2018-12-26 17:08:53.201 Detail, contrlr, Queuing (Command) Add Node Stop: 0x01, 0x04, 0x00, 0x4a, 0x05, 0xb4

2018-12-26 17:08:53.203 Detail, 

2018-12-26 17:08:53.205 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x4a) - Add Node Stop: 0x01, 0x04, 0x00, 0x4a, 0x05, 0xb4

2018-12-26 17:08:53.208 Detail, Notification: ControllerCommand - Canceled

2018-12-26 17:08:53.298 Detail, contrlr, Received: 0x01, 0x07, 0x00, 0x4a, 0x0c, 0x06, 0x00, 0x00, 0xb8

2018-12-26 17:08:53.299 Detail, 

2018-12-26 17:08:53.301 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:

2018-12-26 17:08:53.303 Info, contrlr, ADD_NODE_STATUS_DONE

2018-12-26 17:08:53.305 Detail, Node006, Expected reply was received

2018-12-26 17:08:53.309 Detail, Node006, Message transaction complete

2018-12-26 17:08:53.311 Detail, 

2018-12-26 17:08:53.315 Detail, contrlr, Removing current message

2018-12-26 17:08:53.317 Detail, Notification: ControllerCommand - Completed

I’ve tried with previously associated modules and one that has never been associated, same effects…

Any help on this?

Edit: actually it just worked with the new module!
remains the issue with the old ones…


#2

I had a similar issue moving Z wave devices from my QOLSYS panel to the AeoTec Z-stick. Here is what worked for me on pairing the old devices that were previously connected.

In the Z-Wave Network Management Panel hit "Remove Node’ then toggle the Z-wave device wanted. After this hit “Add Secure Node” and toggle the device again.

Lastly I noticed that if the z-wave stick, plugged into the pi at all times, was not 2-6’ from the device being added it would fail on finding the device to add. It might be because in pairing the Z-wave does not use the mesh network but instead relies on direct contact with the device.


#3

Hum I’ve tried that already and it didn’t work… I cannot add the node again
And I tried with the module less than 1m away from the stick


#4

Did you try auto or manual inclusion.

VI. Z-WAVE NETWORK INCLUSION
Fibaro Roller Shutter may be included into the Z-Wave network via
the B-button or a push button connected to the S1 terminal. In
addition, the module may be included in auto inclusion mode, by
simply connecting the power supply.
Automatic Z-Wave network inclusion:
1) Make sure the power supply is disconnected and a Roller Shutter
 is located within a direct Z-Wave network’s main controller
 communication range.
2) Set the main controller into the learn mode (see main controllers
 operating manual).
3) Connect the power supply to include the Roller Shutter in auto
 inclusion mode.
4) Fibaro Roller Shutter will be automatically detected and included
 into the Z-Wave network.
To disable the auto inclusion mode, press the B-button briefly, after
connecting the module to the power supply.
Manual Z-Wave network inclusion:
1) Connect the power supply.
2) Set the main controller into the learn mode (see main controllers
 operating manual).
3) Triple click the B-button or a push button connected to the S1
 terminal.
4) Fibaro Roller Shutter will be detected and included into the
 Z-Wave network

Also any color of LED’s flash when attempting to pair?

Fibaro FGR 222 Manual


#5

I tried both methods, but I realize that between the first setup and now, the zwave network key has changed, could it be the issue?
once a node has been added with a network key, can it be added with another key or should it be reset before?


#6

the key must remain static