Unable to authenticate Home Assistant Companion App with Nabu Casa

I have installed Home Assitant on Pi 4. Here’s some config details

## Home Assistant 0.109.2
System Health

| --- | --- |

Configuration.yaml is as follows [All default]
# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
Installed the latest Home Companion App

I have setup Nabu Casa Account. Remove connectivity from a IOS Browser, I am able to authenticate and see everything working. But the mobile App is not able to authenticate. Here’s the screenshot of what its trying to call the URL with

The errors basically tells me that the App is trying to sent the Auth info through header and defaulting to some wrong data as I never entered by username/password anywhere. It keeps sending ip address or the last subdomain/domain as username. That’s my guess. I have seen many having this problem. To me this looks like an ios App issue or a setting on my phone. I tried two ios phones though.
Any help is appreciated.

SOLVED: It was ipv6 issue. If you have not played around wiht ipv6 defaults (like me) I just had to reboot the modem, router and haas in that order and it worked.