Unable to boot home assistant in virtual machine / starup.nsh error

Had the same thing happen when I cloned a VM in VirtualBox. I tried the edit with fs0, then saved the edit and just typed exit, because I thought that would get me out. It took me to the BIOS interface, and when I picked the HA disk in the boot order, it immediately booted right up. So it looks like just fixing the boot order solves the problem.

This work to fix previous problem, but now I have enp0s3 ipv4 address problem…any help? Restarting router didn’t help this time.

Edit: My fix was to change the Bridge Adapter from ethernet to wifi.

Lifesaver!

1.fs0: gives me: ‘fso: is not a valid mapping’.

I think it’s just my luck. I’m meant to have problems every step of the way lol.

I am also stuck at boot (using KVM virt-manager).
I tried entering the boot64 location but it does not seem to help. It just goes to console and then writes

Shell> SC in 1 seconds to skip startup.nsh or any other key to continue.
Shell> \EFI\BOOT\BOOTx64.efi
Script Error Status: Unsupported (line number 1)
Shell>

Nothing happens afterwards.

Also tried manual installation. Also fails.

~/home-assistant $ virt-install --name hass --description "Home Assistant OS" --os-variant=generic --ram=2048 --vcpus=2 --disk /home/piserver/home-assistant/haos_ova-10.3.qcow2,bus=sata --import --graphics none --boot uefi 
Starting install...
Running text console command: virsh --connect qemu:///session console hass
Connected to domain 'hass'
Escape character is ^] (Ctrl + ])

BdsDxe: failed to load Boot0001 "UEFI Misc Device" from VenHw(93E34C7E-B50E-11DF-9223-2443DFD72085,00): Not Found

>>Start PXE over IPv4.
  PXE-E16: No valid offer received.
BdsDxe: failed to load Boot0002 "UEFI PXEv4 (MAC:525400576260)" from PciRoot(0x0)/Pci(0x1,0x1)/Pci(0x0,0x0)/MAC(525400576260,0x1)/IPv4(0.0.0.0,0x0,DHCP,0.0.0.0,0.0.0.0,0.0.0.0): Not Found

>>Start HTTP Boot over IPv4.....
  Error: Could not retrieve NBP file size from HTTP server.

  Error: Server response timeout.
BdsDxe: failed to load Boot0003 "UEFI HTTPv4 (MAC:525400576260)" from PciRoot(0x0)/Pci(0x1,0x1)/Pci(0x0,0x0)/MAC(525400576260,0x1)/IPv4(0.0.0.0,0x0,DHCP,0.0.0.0,0.0.0.0,0.0.0.0)/Uri(): Not Found
BdsDxe: loading Boot0004 "EFI Internal Shell" from Fv(64074AFE-340A-4BE6-94BA-91B5B4D0F71E)/FvFile(7C04A583-9E3E-4F1C-AD65-E05268D0B4D1)
BdsDxe: starting Boot0004 "EFI Internal Shell" from Fv(64074AFE-340A-4BE6-94BA-91B5B4D0F71E)/FvFile(7C04A583-9E3E-4F1C-AD65-E05268D0B4D1)




UEFI Interactive Shell v2.2
EDK II
UEFI v2.70 (EDK II, 0x00010000)
Mapping table
     BLK0: Alias(s):
          VenHw(93E34C7E-B50E-11DF-9223-2443DFD72085,00)
Press ESC in 1 seconds to skip startup.nsh or any other key to continue.
Shell> 

Try this guide to configure your KVM.

I have an Oracle VM Virtual Box running my HA.
In my case this had to do with the Boot Sequence that follows some default when you create a new VM
The solution below is easy and permanent.
Enter into the BIOS setup of the VM (possible pressing ESC when you see this screen):
image

Now search for the option to change the Boot Order.
This is what I had:
image

Make sure that your UEFI VBOX HARDDISK comes first.

Make sure to save the change, reboot and everything should run smoothly. Good luck!